ReachView3 can’t connect to RS+ units

I just purchased two new RS+ units. I did the “First setup”, updating each unit’s firmware from 2.22.7 to version 26.4. After some troubles with wifi, I did eventually get that update to complete in each unit. After each update was complete, I powered down the unit. Later I powered up one RS+, and ReachView3 on my Android phone cannot see that unit (even after many minutes waiting). Same result after powering up the second unit. With my internet wifi network turned on and the phone connected to that wifi network (with mobile data turned off), powering up the RS+ gives the following LED indications after a minute or two:
PWR solid orange.
NET continuously flashing blue, on one second, off one second…
STAT continuously flashing green, on half a second, off half a second…

With that not working, I tried this: With my internet wifi router off and an RS+ powered on, my phone wifi can see the device hotspot “reach:C5:B5”, and can connect to that wifi network, but while connected to that network the ReachView3 app can’t find the RS+, even after many minutes and many “refresh” attempts. Next, with the phone connected to the RS+ hotspot, I used the phone browser to access 192.168.42.1, but nothing came up.

What am I doing wrong?

Update via firmware updater on the computer instead, and you should be good to go.
The next firmware you should be able to do as usual from ReachView

After fighting with this another 3 hours, the suggested “update via firmware updater” worked, (after searching for 15 minutes trying to figure out what “update via firmware updater” means, and where on your website to find it and the correct set of instructions to use it). Thanks for that very helpful but slightly cryptic hint! A link like this would have been most helpful:
https://docs.emlid.com/reachrs/reach-panel/firmware-reflashing

As a brand new owner of two RS+ units, a beginner in surveying, and fairly experienced with technology, software, apps, computers, etc., I have this observation at this point in time…

The setup instructions for the RS+ are written for an experienced user of this equipment, the app, and the website. Too many important steps are not included in the instructions. It seems we are expected to be experts and know our way around the app and hardware and website, yet as brand new owners we are starting with zero experience with the Emlid tools. A good example of the “written for an expert user” is the “update via firmware updater” suggestion provided above.

When things don’t go perfectly, the tools and instructions give little or no help identifying or resolving the problems I ran into. Try handing one of these devices to a complete noob and watch EVERY SINGLE THING they do to try to get things setup and working. That will help you see the missing steps. If they have to press a button on the hardware or the app, it should be written in the instructions. 95% of the time it’s there, but those missing or incomplete 5% are killers! If we need to wait 60 seconds for something visible to happen on the app, that should be in the instructions (in most cases it’s there, in some cases it’s not).

At this point I would not recommend the RS+ device to anyone I know because it has been so incredibly frustrating getting these two units up and running. Hopefully I’m now past that frustration and will have a more pleasant experience as I put these units to work.

I am right there with you… yesterday I got 2 new RS+ units … 3.5 hours to do a simple firmware update on the first one, and the second unit BRICKED itself. SO I AM 7 HOURS IN ON FIRMWARE UPDATES AND NOW HAVE A USELESS PAIR. I AM WAITING FOR A RESPONSE FROM EMLID

Hi @hogwild,

The behavior of Reach RS+ you’ve experienced is not common. It seems like there was a software glitch that didn’t allow the receiver to pass the time sync procedure: it can be seen from the LED status you’ve described. So it’s great to know that the reflashing procedure restored the condition of the unit!

Still, working with our docs shouldn’t be a struggle. We’re always striving to make our guides and instructions as easily read as possible. That’s why we’ll appreciate it if you point out which parts of our docs were not fully clear for you. We’ll think about how we can make them better.

Regarding the unit’s settings, you can always contact us here on the forum or via support@emlid.com with any questions. To start working with Reach RS+, I’d recommend going through the following videos:

2 Likes

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.