ReachView v2.23.9 is out for all devices

I upgrade to 2.23.5 version all ok, then I press reboot and go to the app but the device stays loading, try reboot and again the device dont start, it have 15 min and stays loading. (3.6 MB)

Try accessing the unit from it’s usual IP and then add :5000 to access the update-page. Then you should be able to re-update.

Hi Edgar,

Is it possible to access the device in the ReachView app?

Hi Polina

It was not. I reflash the unit and now I can access vía Reachview, the problem now is that when I access it shows only the update screen (the screen that shows when you is going to update, test wifi, down loading state, etc.).


Hi, Edgar. Excellent, ok front that point you have to enter the name a the password of the internet- wifi you are connected to. Reach view do not detect automatic wifi, you have to enter it.
I believed your problem was that during the actualization process the first time you loss internet connection.

Polina, Miguel

The problem seems to be solved.



Thanks for the update!

Was the cause of the issue the Internet connection loss as Miguel suggested?


Ther was not Internet connection loss, the problem was that when I turn on the Rs2 and then connect via reachview the only screen that appears was the update screen, but after some rebots there return to normal screen.

Sorry for my english


Edgar, thanks for the explanation!

We’ve just released the v2.23.6 version that should resolve the updating process misbehavior. The full list of fixes is available in the first post of this thread.


Hello, guys!

We just released v2.23.8. The list of changes is available in the first post of this thread.


19 posts were split to a new topic: Reach RS+ results discrepancy on v2.23.8

Hello, guys!

We just released v2.23.9. The list of changes is available in the first post of this thread.


A post was split to a new topic: WKT format for projects

3 posts were split to a new topic: RS+ fails to update to v2.23.9


We’ve been using the RS2s for a year with great success. I recently downloaded v2.23.9 on one of our units to test Reach View 3. One thing I noticed was that v2.23.9 does not apply the base antenna height to the Height of the base coordinates. I tested both Reach View 2 and Reach View 3 on known stations and the height was off by the base antenna height value (measurement to base of RS2 + 0.134m). If I used the elevation of the antenna reference point (monument elevation + height of antenna reference point) for the Base Height coordinate then the surveyed heights were correct. Currently it seems like the rover with v2.23.9 is ignoring the base antenna height value.

By the way - Reach View 3 is a great new development!



Hi Dave,

This happens when the rover is on the latest dev (2.23.8+) and the base is not and you are entering base position manually. So to solve this there are two options:

  1. Update ReachView on the base station. Rovers with with any firmware version will work correctly with this base.
  2. Enter the base elevation with antenna height included.

We had to change the way we handle antenna height as it was not consistent with the RTCM standard. It only showed up in some exotic cases, but we decided that it was the right thing to change it now. Unfortunately there is one situation, where it leads to an error in height: older base firmware + manual entry + rover on 2.23.8 or higher.


@igor.vereninov Thanks Igor - that makes sense.

I can confirm that this error showed up with my base on dev 2.23.6 and the rover on mainstream 2.22.x (sorry but I didn’t check the actual version prior to updating) it did not account for the antenna height in the manual base position. Since updating both units to dev 2.23.9 the issue appears to be solved.

1 Like

A post was split to a new topic: Can’t update to v2.24.2

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.