Emlid

Community Forum

ReachView v2.2.7


(Egor Fedorov) #21

The modem we tried is ZTE MF823D, with D in the end. Can you confirm you have the same?

Did you wait for a status led on the modem to light up?

For debug purposes, I will need you to post output of the following commands on Reach after seeing that the modem booted

  • ifconfig
  • lsusb -t
  • dmesg | tail -n 100

(Benedikt) split this topic #22

3 posts were split to a new topic: Huawei E3372h-15


(Christian) #23

Hi Egor,

now i got the ZTE MF823 (without D) successfully running.
The solution is to add a new Gateway-IP to reach.
Like descripted in this thread: ReachView v2.4.0 - Galileo support

Thank you for helping me :+1:


(l3technologycambodia) #24

Can anyone kindly provide instructions or tutorials on how to connect 3G/4G USB model with Reach RS? Using hot-spot from mobile phone is not a good solution because the phone will be very hot and battery comes low very quickly. Thank you so much in advance.


(Daniel Koffler) #25

Could you elaborate on what changes were made to enable 3G/LTE USB modem support?

I’m interested in connecting a NimbeLink SkyWire modem or a standard USB dongle 3G modem to my Reach RTKs.

I have upgraded to ReachView 2.2.7, but I notice on my reach that there is still no PPP packages installed. So I guess I have a couple of questions:

  1. What is new in ReachView 2.2.7 that enables the 3G/LTE support?
  2. How would I go about modifying the Reach RTK image to include things like the PPP applications?

(Egor Fedorov) #26

Hi!

This version added cdc and rndis ethernet kernel modules for Linux. We don’t really support PPP. If ifconfig does not create a new interface automatically after the modem is powered up, it will need some debugging. Please post output of dmesg - last lines after connecting the modem, ifconfig, lsusb.


(Egor Fedorov) #27

Easiest way is to set your modem with a Linux laptop. If it creates a new network interface(via cdc_ether or rndis) and no additional setup needed(like activating your data), you are good.