ReachView not working on Android

I’ve followed the QuickStart Guide however RachView isn’t working on Android? I’ve tried two phones and it’s the same.

Connect to Reach M+ via Wifi - ok
Open ReachView - ok (says Reach M+ and an IP adress of
Click to connect - Screen goes Black and nothing happens?

Any ideas?

OK for the benifit of other users I managed to figure out a way to get it working using an Android Phone, Android Tablet, Windows PC and Home Wifi Network.

The phone didn’t work with the ReachView App and just gave me the back screen once I tried to connect, so I managed to connect the the Reach M+ using the borwser on my Android Tablet ( This enabled me to get as far as adding My home Wifi Network.
However it displayed an error saying that Reach was trying to connect to another network etc. But when I checked on my router setting using my Windows PC Reach was indeed connected and working on IP adress I tried to load this address in my browser but nothing happened, however I could ping the adress to prove it was indeed connected.

So back to my Phone (now connected to the same home network) using the App. and this time it worked and I was able to update the Reach firmware.

It sounds like you’re getting close.

Maybe try port 5000 of that IP address:

If not, then just try the default port again:

If the screen is black, just wait. Maybe wait up to 60 or 120 seconds, just in case it is loading very slowly.

You could also try to move Reach and your phone closer to the Wi-Fi network antenna.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.