ReachView and the reach M+

I have been having serious trouble using ReachView the App with the new Reach M+. BUT the direct web browser approach works fine.

The app finds the unit. But hangs with. Blank black screen when I tri to access it.

Putting the IP address in chrome work within seconds.

I am using the Apple app.

Reach RS (non-plus) units here. Since day one the app has always been like this, but I just open a browser anyways with ip and always fine that way. Android 8 here. I rarely use the app anymore.

Thanks for the response.
I have 2 RS and the Apple app worked for me, but the android app was poor. With the M+ this is a whole new level of not working
I post it here as Emlid should know about these little quirks.
I am having a lot of problems with my Reach M+. It is not as pesponsive as the Reach. Having serious problems connecting to networks by wifi, maybe 30% success rate from cold start, and of that 30% a further 10% don’t get rtk position without first intervening and going to single mode first.

The app never worked for me in Android 8, but it does work in the Android 9 Developer Preview.
The workaround was to just open the displayed ip address in the browser.

I am guessing Emlid uses Apple Bonjour to broadcast the IP. Maybe Android simply doesn’t like this protocol.

It’s not mdns that is the problem. The Reach shows up in the list and the ip is displayed. It’s the web interface that does not work in the app.

My guess is that it’s one of two things:

  1. That ReachView web interface uses some Javascript API that is not available in the web view and therefore crashes.
  2. That Android decides to route web traffic over LTE when it discovers that there is no internet access on Wifi.

What makes me suspicious of number two is that Android 9 DP displays a dialog asking if I’m sure I want to use the selected wifi network as there are no internet access. Older Androids never displayed such dialog and may just have assumed that I do not want that.


We’ve recently pushed an update to the App store. Can you please check if you have the iOS app updated to the latest version?

Reach M+ software 2.14 stable and new Reach app on IOS 11 all working well together and getttin good fix. Thanks

1 Like