Reachview 3 logging "use antenna height" bug?

I’m a newbie, bought a Reach RS2, and want to get set up to log for PPP via CSRS. I’ve updated my RS2 firmware to 29.2 and have ReachView 3 under iOS all updates applied. I connect to my RS2, select “Logging”, then “Settings” under “Raw data”, pick “CSRS” and select “Use antenna height” to allow me to enter measured height. But in the value box I can not enter more than 1 digit. It looks like a software bug; some googling shows others successfully using values to 3 decimal places.

What happens is if i enter 1, then the decimal, the 1 changes to 0 and my phone suggests I am sending a string of values but the box never fills. When I hit the iOS “Done” button the value box contains only the last digit I entered.

What am I doing wrong?

Hi Robert,

I’ve never faced anything similar. Can you please share a screencast of the issue? You can do that using Google Drive or WeTransfer.

Robert,

Thank you for sharing the video! Yes, I see it now. I checked it on my Android phone, but wasn’t able to catch the issue. I’ll test it on iOS as well. What is your phone model?

As a current workaround, you can record raw data logs without setting the antenna height in ReachView 3. Once the log is recorded, you can open it in a Text Editor and enter the antenna height value in the ANTENNA: DELTA H/E/N line of the RINEX header manually. Let me know if you need any help with this.

1 Like

My phone is iPhone 11, Model MWJ02LL/A running iOS 16.0 (20A362).

I tried installing ReachView 3 on my iPad and initially it exhibited the same behaviour, but then remarkably it started working as expected. I was able to add the antenna height in the app on the iPad. I checked just now again on my iPhone and the problem persists.

Thanks for the workaround suggestion!

Hello, I also have this same problem using my Samsung cell phone model S10e!

Hi @alan.pizzinato, thanks for reporting!

Guys, I did some more tests and caught the issue as well. Give me a bit of time to discuss it with our devs. I’ll keep you posted on that.

I also noticed that once I updated the receiver to 30 Beta 1, the issue disappeared. Can you please test whether it helps you too?

2 Likes

I updated to 30 Beta 1, and yes, the issue disappeared.

Also, BTW, nice interface updates in 30 Beta 1!

1 Like

Robert,

Great! Glad to hear it works fine for you.

This fix will be in a stable 30 firmware version as well. But if you want to work with the current stable version, 29.2, you can use a workaround with manual setting the antenna height in a text editor.

Thank you! I personally like it too :slight_smile:

1 Like

Except … I can not get the RS2 to start logging with 30 Beta 1 installed. So I can set the antenna height, but when I press the “start logging” button nothing happens.

Hi, Robert

Please, try to reset the receiver’s settings to default from the Troubleshooting page

1 Like

Any idea when the beta 30 version will become stable and released? I’m having the same issue with not being able to enter antenna height.

Hi Robert,

Did you have a chance to try resetting the receiver’s settings to default, as Dmitry suggested?

Hi Brad,

Welcome to the community forum.

We don’t have the exact dates of the 30 stable release for now. But is there a chance that the workaround with the manual setting of the antenna height in a text editor works for you? Have you tried it?

I haven’t tried the manual method but will. I was just curious about the release date. Thanks

1 Like

That did the trick! You folks are awesome.

2 Likes

Great news! Thank you :relaxed: