Reachview 2.20.6 Android connection issue over mobile hotspot

Hi everyone,

Recently purchased two new RS2 for evaluation purposes and already running into issues (not a good sign)

Reachview app:

Handheld device: OnePlus3T, Android 9 running OxygenOS 9.0.4 June 1, 2019 security patch

  1. Can’t connect to Reachview via Android app when on Reach’s WiFi network with handheld mobile data on. Constantly get:

As soon as put my device in airplane mode and try again it connects (yay!)

  1. Start up mobile hotspot on my device, Reach connects to it (solid blue Wifi) and I can see the device on my hotspot manager:

But when I try to connect via Android app I can see the reach on the network but can’t connect:

I try typing the IP into Chrome on my handset and still won’t connect:

However connecting my PC to my hotspot and typing in the Reach IP works. So why can’t the handset connect when using hotspot??

1 Like

Mine does all of that but it depends on the android phone I use, the most important is that you can get into the RS2 whether it be a PC or whatever android phone that works so that you set up the hotspot. Once it is set up like you have done then you have to fumble around to find out what you can actually use, For me my Pixel 6 makes the hotspot and the reach connects to it upon boot up. If I do it this way I can connect with the app or using the browser. If I then turn off the hotspot on my pixel 6 and have the reach join my local wifi and the pixel joins the same wifi it will never find the RS2. But if I whip out any of a bunch of android phones like a nexus 6p the reach app see’s the RS2 and can make a connection. I know it’s a hassle but it is getting better like I said you have to find a method that works for your hardware at this stage of the game.

I cannot connect to the mobile app when using a mobile hotspot with a Samsung Galaxy S7 or S8. I also was unable to connect to browser app at first. I figured out that the IP address that I was using for the mobile hotspot was not correct to view the app in the browser on the phone. I found the correct IP address by going into the mobile hotspot settings on the phone and looking at the devices that were connected to the mobile hotspot. I clicked on the Emlid Reach RS2 and wrote down the correct IP address that was shown here. With the correct address, I was able to access the app through the browser on my phone with no issues.

I have to agree that this does not look good and that it may be inconvenient at first, but for me I look at it from the perspective that some alternatives cost 6 times as much money and you still need to buy a separate data collector and then pay for the software.

I also see Emlid employees posting on this forum which tells me that they are listening and I’m confident the app will only become more robust in the future.

I hope that you find a solution and get to test this device. I am currently testing the RS2 as well and so far have put it to good use at a surveying and engineering company.

5 Likes

Now that you mention all this , that was my problem today as well with the apple app.

@jmd11mtb would you mind showing where to see the devices connected to your hotspot and the associated IP? I couldn’t seem to find anywhere in my settings that showed that information. I’m simply using the IP address that shows up in the Reachview app. It would make sense that this is IP perhaps incorrect.

‘Fing’ is one of those network apps that tells you what machines are on your LAN.

Chrome has been the browser of choice.

1 Like

I tried Fing but no luck as it wouldn’t recognize my network. Upon further reading there is an issue with OnePlus devices and being able to see the IP address of other devices on the hotspot. Other OP users have reported this issue when attempting to use the raspberry Pi. The workaround seems to be to install a terminal emulator and use the ‘ip neigh’ command. I’ll try this on Monday when I’m back in the office.

1 Like

This is the main motivation behind my evaluation. My company operates an ever aging fleet of Trimble equipment. Upper management wants to look for more cost effective options as the Trimble units go down and look to expand our GNSS fleet across more BUs.

My job is to ensure quality and easy of use are not sacrificed for lower cost. Little things like the app not connecting aren’t necessarily deal breakers, but can definitely cost man hours resulting in lost productivity. I field enough calls as it is with the Trimble equipment.

It’s looking to me like using the internal SIM slot is a better way to operate for internet connectivity (NTRIP). Combine that with a dedicated handset for survey control. Anyone have hardware recommendations for the handset?

Mesa2 from Juniper ,You can also get a andriod version of Mesa2 . FieldGenius is now availble in andriod

1 Like

Could you check if there is a 2G or 3G signal being used?

@TB_RTK on my handset, yes the mobile LTE was engaged when I was trying to connect to Reach’s WiFi network. I disabled handset mobile data and connectivity with Reach’s WiFi network immediately worked. However, there is no mobile SIM currently in the Reach unit itself if that’s what you’re asking?

OK, thanks for your feedback.

Hi @conehead,

To access Reach over hotspot mobile data should be disabled.

This issue is related to an Android OS and it’ll be fixed in one of the future version of ReachView app. It appears not on all Android devices, so there should be devices that work fine with Reach.

However, it should be possible to access Reach over a browser from the same device. I see that you were advised to try Fing up to resolve Reach’s IP address. You also can try using Zenmap or Nmap tools: just to make sure ReachView defines Reach IP address correctly.

Please keep us updated.

The powerful Xplore M60 6" Android rugged tablet has been a popular and cost-effective choice for many of my clients to use as an Android controller… 15 hours battery and it fits in your pocket. Even Trimble have white labelled this little beauty as the TDC600 - although not sure at what cost :wink:

When the Reachview connectivity issue rears its head, Bide is right that Fing is a great app to track down the IP address of Reach RS+ when it is in client mode. It is always 192.168.42.1 in hotspot mode.

Knowing the IP address allows you to load Reachview in a browser - again I agree with Bide in that Chrome is a good choice.

3 Likes