Reachstill no fix

Wasted another afternoon trying to get fix. The screen showing 10 green satellites with grey bars beside each and still only get single never even float?

This is starting to get frustrating. Have other things beside this to do.


If your only getting single means the rover isn’t even using the base corrections.

  1. Make sure you have correct coords setup in the base unit.
  2. Make sure the link latency is less than a few seconds. Not for sure the official on Reach but other RTK systems normally are ok with 1-2 latency.
    3.Make sure you have proper configs on the base and rover. If you have been tweaking I would revert to basic config and then start from there.

If you need to start from scratch would start here, IIRC you should get float in less than a minute, normally few seconds for me.

I thought the grey bars beside the colored ones meant the base was working?
I tried for several hours with different configurations that were suggested in other threads none seemed to work for me.


From my understanding the grey bars do mean the corrections are coming in. But if your still single the entire time I think that means rtklib is rejecting them all together. I’ve had something similar happen but had wrong base coords from previous location entered. Once updated base coords got float very quickly. Fix is another story :smiley:

1 Like

Thats good to know. I have been having trouble with the elevation tried several different things with that. Updated to version0.45 after I was done today will try again tomorrow and see.


at me the solution was in advanced settings:


Changed : fix and hold
Lock,count from 0 to 200
Ar from 3 to 2

pos2-armode =fix-and-hold # (0:off,1:continuous,2:instantaneous,3:fix-and-hold) ## GPS integer ambiguity resolution mode
pos2-gloarmode =on # (0:off,1:on,2:autocal) ## GLONASS integer ambiguity resolution mode
pos2-arthres =2 ## Integer ambiguity validation threshold
pos2-arlockcnt =200 ## Minimum lock count to fix integer ambiguity

I tried most of these yesterday as I had seen your post. I will double check that I got them all.