Reach will not connect to iPad after Flash to 2.22.3

I have sent in a tickeet on this but in case anyone else runs into this issue.

The final issue appears to be that after flashing to 2.22.3 I cannot talk to them from my IOS 10.3.3 iPad using IOS Reachview app, Safari browser, Chrome browser. I can talk to them using Windows Chrome or Edge browsers no problem. I can talk to them using an iPhone running IOS 13.3.1 using any of Reachview app, Safari or Chrome no problem.

Here are the steps taken in figuring this out.

Two original Reach modules were running Reachview 2.16.? (hadn’t been used for a while)
Using iPad running IOS 10.3.3 (old iPad) and Reachview App I upgraded them over the wifi to Reachview 2.20.8.

Once they were updated and running fine on 2.20.8, still using iPad I connected and saw a message that in order to stay current these needed to be reflashed. Also warned that all settings and files and projects etc would be wiped… In self quarantine after travelling to the USA from Canada for another week so I have LOTS of time so I went for it knowing that firmware upgrades can go pear shaped fast.

Installed (windows) Flash utility and Intel Edison drivers. Reflashing went fine.

Ran IOS Reachview app on iPad and the reflashed unit showed up and I was able to connect for the first time dialog and set my wif up then I had to power cycle.

Then when I connected I again saw the first time steps run and it got to the Reboot and go to the app stage.

After that reboot I was completely unable to connect using the same iPad ever again using either IOS Reachview app, Safari or Chrome…

I thought the Reach module was not actually booting up properly. I tried to connect using SSH (Putty) and logged in using username password reach and emlidreach

I could connect with Chrome on Windows…

Appears to be an IOS issue and only old IOS versions.

Hi Terry,

This is interesting. I believe this is something we should test ourselves first. We will try to get an iPad with this firmware and reproduce this.

Give me a mailing address and I will send you my iPad. I can survive without it for a while.

This is the latest iOS this iPad can accept at its age so it’s stuck there. It is a 4th gen MD514V/A model A1458

I am also just about to wipe the iPad and start fresh with it to see if that changes anything.

Wiped the iPad. Fresh start. Zero apps installed (not even IOS Reachview) and when I connect to the freshly booted Reach with Safari it hangs and never gets past the first screen… I should add that I see the grey screen, then the dark grey EMLID in the middle, but I never see the EMLID turn blue from left to right like it does on a working browser. Is this where I get to say that while that splash screen looks cool, after about the 10th time of connecting you start wishing it just went straight to Reachview instead of that time consuming splash screen? When swapping back and forth between different units on different Wifis you see that splash screen way too many times :slight_smile:

1 Like

And FYI I decided I had zero to lose trying the DEV version 2.23.3 so I upgraded to that and still the same result.

And more to add to this… In the process of flashing BACK to 2.22.3 from the DEV version I tried using browser only since I had wiped the iPad and hadn’t installed the Reachview app back onto it.

I connected my Windows machine to the reach hotspot wifi and connected using chrome and similar to what I had mentioned in my long description on the support ticket I entered when I connected I got the first time screen that asks for Wi-Fi setup so I enter and save my wif SSID and password. After clicking save everything remains greyed out. Doesn’t move forward. So I end up power cycling. When I did this from Reachview on the iPad, on power cycle it connected to my wifi that I had just saved. But htis time when I saved from Chrome on Windows and rebooted it did not connect and still gave me a reach hotspot. I tried again, same result, I tried from Safari on my iPad and same result. I was getting a little desperate so I reinstalled Reachview on the iPad and tried from that… same result… back to hotspot, my wifi not saved. Then I decided to throw a little patience into the mix. After I saved the wifi settings and got the “saved” message I waited… Then I checked from another device and it actually showed the same screen WITH my wifi shown in the list (still no Time sync or Update check or Reboot and go to app available). I power cycled and this time the wifi settings took. Phew… not bricked. I can talk to it and configure it from Chrome on Windows now again.

1 Like

Hi Terry,

May I ask you to accomplish a test I sent you in PM?

Please keep us posted.

Confirmed. Use command line dug-util and reflashed 2.20.8 and iPad works fine with it again.

Sorry. Noticed typo. Used command line dfu-util and reflashed back to 2.20.8 and the module now communicates fine with the iPad using either Reachview IOS app or Safari or Chrome browsers.

1 Like