Reach View 2.2.5 USB to PC solution output

Reach View 2.2.5
Ubuntu 14.04

I can see in the position output a USB to PC and a baud rate. I am guessing this turns the usb port on the reach to serial for output of the solution. I tried this while it was powered from my laptop. My computer never saw the reach. Have I misunderstood what this does?

I have never tried what you are trying to do myself, however based on what I have read on this forum, you need to have an adapter similar to the ones I have listed below. The adapter converts TTL voltages (~3.3 volts) to USB voltages (5 volts). I would first check to see if the adapter you want to buy is compatible with the OS running on your PC (i.e., drivers are available or built into OS).

That is what I was doing. Are you using Reach View 2?

Serial on your Ubuntu should be something like /dev/ttyACM…

Can you show us your dmesg when you attach Reach with USB cable to it?

Nothing changes in dmesg and nothing changes in /dev

reachview says connected to /dev/ttyGS0

How are you connecting Reach to your PC?

The usb mini port

With the normal USB-to-microUSB cable? (not otg)

Yes and with this config.

  1. Plug Reach out.

  2. Now open console on Ubuntu and enter: dmesg -w

  3. Plug in Reach in your computer, wait for it to load and show us a screenshot of dmesg after Reach is fully loaded.

Ok tried a different computer that I did a clean install of Ubuntu 16.04 on and I am getting this now.

ttyACM0 is the device you are looking for

It appears the IT people locked out my other two machines from adding anymore usb/acm devices