Reach & Survey Master - Third party application for advanced survey

Creating a thread for a third party application, aimed for the advanced users.

This app is on Android only but free atm.
Survey Master

It has many highly wanted features like COGO, site calibration, custom geoid/crs, line work etc
I have youtube channel you can see the application in action and where i test out features.

I`ll update this post when new clips are out.

Setting up project with custom CRS and GEOID

Reach RS2 & Survey Master - different stakeout displays

Reach RS2 & Survey Master - Apply site calibration (Localization)

Reach RS2 & Survey Master - Stake line

Reach RS2 & Survey Master - Georefrence CAD file with 3 point site calibration


This is great! Thanks
Have you had trouble with random disconnecting? I had some when testing.
Also is localization possible where you upload a non georeferenced CAD and just go on site and locate yourself? On my total station it’s called set up with reference points.


The disconnecting thing seems to have disappeared. Mine is really good with a Huawei phone. It does disconnect when the screen is off but quickly comes back again. May be just my phone that does that.

Can’t comment on the CAD stuff as I use coordinates exclusively.


EMLID just needs to provide these MUCH NEEDED solutions in an APP that goes hand in hand with their products, it’s more than GIS now… to keep income coming in with an APP, without their hard work being distributed around for free, probably subscription. By requiring a internet sign on every month to authorize use of it. It would be incentive for them to keep it bug free and new needed added features. Like Adobe does with their Creative Cloud suite.

1 Like

I had issue before. In 2016 more specifically Reach - Bluetooth related and app talk

I use this connection setting

Also had some issue with toposurvey displaying me in the wrong place, but turning of the wifi fixed that. Talked to support but they didnt know what the issue could be.
Strange thing, at work this doesnt happen

Will try a CAD import later


Allright. From CAD to Survey Master worked flawlessly.
I used a georeferenced file.
Converted a Norwegian .sosi file to .dxf and imported lines. Dots is an option too
Awesome. This makes my job alot easier.

I would think a NON georeferenced dwg/dxf file would be easily done with site calibration.
I`ll see if I manage to get some videos about that too.


Any special setting in RS2? or just normal output NMEA via bluetooth?

1 Like

Normal nmea yes


Good work as always, thank you for sharing! Will give a try.


I use it for a while I havn’t a trouble with connection just have the problem of bluetooth connection at the beginning but with following the steps of JAGUERO

I can connect easily without any interruption after.

Yes it works good! I use at least three control points (using three options H.only, V.only or H & V) by running the calculation the residues must be minimal.


Added a new clip with link in the first post. Import cad for 3 point site calibration. Enjoy


Is it possible to use a Reach RS with Survey Master? I am connected, and can view NMEA string in the app, but I don’t understand the Rover Work Modes- and without selecting one, I can’t collect points.

When you get the rover/base selection after having connected to the rover, you just hit cancel.
I guess its this screen you mean. just hit cancel

Thanks- Survey Master now says connected, but the position is not available.

I see that you are connecting using the T300 device, I have the same results using this or NMEA.

It seems like if I use “Controller GNSS” I could use the mock location of Android from the Reach, but I’m not sure if this is optimal.

Use T300. Nmea is bugged.

Still no dice.

I can connect with the Tersus Nuwa app, which is very similar to Survey Master. No idea why the connection is working here though.

I just tried with my old RS and it connects fine. I am using Samsung S5
Is your phoned added as a device under paired units in Reachview? and you have it visible in Survey Master?
Does the connection drop or does it never connect? Or are you connected but no coordinates? What device are you using?

I notice you run 2.18.0 which is an older firmware version.
Not sure it has anything to do with it… Are you able to update?
Edit: From you picture it looks like its connected. Do you have a solution? (Antenna not inside)-

Yes- currently connected- H-Terminal in Survey Master shows NMEA string. And the connection seems stable. However, no position is shown in Survey Master.

Attempting to use Nvidia Shield and Samsung S9, both paired in Reachview.

Solution fluctuating between Float and Fix. Perhaps Survey Master requires Fix?

Will try to flash Reach to v2.21.1.

A solution is good enough.
If you use controller gnss instead and no mock location (just your phone). Are you able to get coordinates?