Finally i started my reach adventure too.

Everything goes pretty well, i am able to get a float/fix connecting base and rover over internet with 4G.

I setup MP as shown in the docs with all parameters set correctly (it is beyond me understanding why Navio manufacturer uses Pixhawk in the documentation of their products…)

I added status of the 2nd gps in the hud but i never get any 3,4,5…always zero (rover is indicating a fix in the meantime).

Now, since i checked 1000 times all the parameters and all look good, there is only one left that is not mentioned in the docs, SERIAL4_PROTOCOL i have it set to 5 (GPS), is this correct or i have to set it to 6?

Maybe i didn’t understand fully and i need to start Ardupilot with some switch to have it working???



what does satcount2 say? (flight data - status tab)

From memory the first GPS is the navio2 GPS unit and the reach is the second? I think its something to do with the the ERB protocol. Last I used the reach I never got any satellite info in MP and always verified the results with rtkplot, or the fact my rover wasn’t jumping all over the place :slight_smile:

Now if you are using the Reach as primary and another external GPS, not onboard, you’ll need to pull in the latest changes from APM as the GPS auto type was being ignored and pushing UBLOX blobs on startup, sometimes halting other receivers, Send GPS startup blob only if GPS_AUTO_CONFIG=1 by mr337 · Pull Request #4636 · ArduPilot/ardupilot · GitHub

satcount2 says zero all the time.

lat2: 0

I am able to get float/fix as soon as reach starts but it looks like reach can’t communicate with navio somehow.


missionplanner: is serial4 baudrate set to 38 ?
Reach (rover): solution1 output:
solution1 output format: ERB

(Do you inject the GPS with missionplanner or seperately over LTE?)

yes, followed the docs.

Serial4 baudrate 38

Rover solution output 1:


On serial4 what kind of protocol? Number 5 (GPS) is correct? Or 6 (default)?

I am using the serial on top where the usb port is on the reach.
Separately over LTE

serial_protocol 5 is fine
so actually your reach is using usb_otg to connect with navio and uart on navio-in?
and wifi for corrections?

I am connecting to the onboard wifi to the router to get base corrections and it works because i get fix on the rover.

Than i use uart to uart cable to connect to navio, and i think this is where the problem is.


yeah you’re right that’s where the problem is; physical connection seems to be right;

are u using the latest image and arducopter? 3.4-rc4?

Yes latest 3.4-rc4

It looks like it doesn’t take in consideration what comes trough uart.

It looks like a protocol problem or a bug somewhere.


I even tried to attach the external 3DR gps while i was testing the external magnetometer and i don’t get any info from that either, no lat no long and no status.

Maybe it has something to do with the way i start Arducopter with option -A???


Maybe i should start arducopter like this?

sudo ArduCopter-quad -A udp: -E /dev/ttyAMA0

To have telemetry over UDP to my IP and external secondary GPS on serial?



Made some testing with

sudo ArduCopter-quad -A udp: -E /dev/ttyAMA0

It works!!! it now sees Reach, it shows satcount2 and all the rest.

it switches from 3 to 4 and 5 when it goes from single to float and fix.

So i guess everything works now.

I am still wondering if it is ok what i did.


yes that is the correct way to start APM with a secondary GPS; APM automatically uses to the more precise GPS if you set gps autoswitch to 1;
so i guess - SOLVED

Yes, i set a parameter to use secondary when rtk is in float or fix (it is a 0-50-100 parameter).

All major issues solved, hope it’ll help somebody else in future.

One last thing, it is normal that i see only 8 sats on secondary and 16 on first gps(same antenna and position)? It is because Reach is L1?

Thanks again for all support.


make sure to use GPS and GLONASS 5hz;
but if you have 8 good sats with reach plus corrections, then you will have precise position data - rtk gps cares not so much about the number of satellites - more about “good signals”; so add a ground plane (10x10cm), place antenna in the center, make a hole for the cable and observe!

Yes, using GPS and GLONASS 5hz

I easily get float but fix very difficult.

I’ll make the ground plane and see if it gets better


I am a surveyor building a UAV to help with our Topo’s and large area surveys. I have the reach kit (base and rover) and have achieved great RTK results (1-2 CM after fix).
I plan on using a Sony NEX 5N camera and a remote trigger based on distance from last image.

For radios I’m using

  1. 915 MHz 3DR for RTK to connect UAV as Rover to Base,
  2. 2.4GHz for controlling the UAV
  3. 5.8GHz for Video/Camera


  1. If I build my UAV with with Navio2, Do I use the onboard GPS for Navigation or should/can I use Reach connected to the Base? if so how?
  2. How do I get the images correctly GEO Tagged?