Reach RX won't turn on


Today I pressed the power button to check if the power is still good since our RX has been sitting in the office for a few days. The light was green so there should be at least 30% left. I pressed again to show it to my coworker but the light wouldn’t turn on. After that the receiver just refuses to turn on for some reason. Currently it is plugged back in but the lights are still off.

Anyone had the same problem? Appreciate any help. Thanks!

1 Like

You may want to try reflashing the firmware.

1 Like

Have you tried changing the power charging source? Also the cable?

Thanks, Florian.

That’s actually what I did and it seemed to be working.

1 Like

Thanks for the suggestions.

I tried reflashing the firmware and it seemed to be working. At least now when I press the button, the light is on again.

1 Like

Hi Paul,

Indeed, reflashing may help in such cases with Reach RX. But don’t hesitate to write us at in case you face any issues with the device.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.