Reach RX and Field Maps on Android

I am having issues with using the Reach RX with ArcGIS Field Maps on Android. I can connect the unit to my phone and select the RX as the receiver with no issues. Field Maps recognizes the receiver and the accuracy comes through. The problem however is the GNSS metadata that needs to be recorded. When the RX unit is selected as the receiver none of the GNSS metadata is recorded (attached picture). So for this I figured I needed to enable the 3rd party GNSS app “Lefebure NTRIP” or something of the like and use that for Mock locations. Only problem is the Lefebure app keeps disconnecting from the unit and does so on every tablet and device I have tried (My RX and my RS2+) which tells me that app isn’t compatible anymore. The only one I tried and could get it to stay connected was GPS Connector app. However every time I open up Field Maps my accuracy is way off. Anyone else encounter this or have any suggestions? By the way I am not using any type of RTK corrections or anything of the like. I only need sub-meter accuracy and the unit is offering around 15 cm horizontal accuracy with a single solution which is great. Thanks!

Hi Ryan,

Setting the connection to 3rd-party Android apps via the Lefebure NTRIP client is our recommended workflow. Normally, it helps ensure a stable connection. So, it’s weird it does the opposite in your case.

Please share these details:

  • What are the tested mobile devices’ models and Android versions?

  • Do you check that the connection drops right in Lefebure? If so, please share a screenshot of what messages you see.

However every time I open up Field Maps my accuracy is way off.

Standalone receivers usually provide only a few meters of accuracy. For better results, we always recommend collecting points with a Fix solution – even if you need only submeter-level accuracy. Float and Single solutions can bounce, which adds errors to the final result. I’d suggest testing your Reach RX with a local Reach RS2+ base or an NTRIP service and checking if it helps solve the accuracy issues.