Reach RTK - no hotspot - how to reset w/o WiFi?

Much as I would like to give firmware version etc, all I can say is this is an EMLID REACH Multi-system RTK GNSS receiver (well, that’s what’s on the cardboard box), and on the Blox side of the device it says EMLID REACH GTK GNSS MODULE. There’s some writing by the QR code:FZEDC 716D 00EGW 501 if my eyesight serves me well.

The issue is that after playing with the device for a bit and using the web interface to reset to factory settings, first it allowed SSH over port 22 and HTTP over port 5000 via its WiFi hot spot, but then I left it for a few days powered off. This morning I was able to use the hot spot HTTP interface over port 80 and thought I’d connected it to a temporary WiFi router: it must have discovered it, but as I’m working in an office I can’t connect the router to the internet (I thought I could but I can’t). Now the Emlid Reach cycles between blue flashing and steady magenta LED colours, but never sticks on white LED (which I understand means “offering hotspot”), and my PC no longer sees “reach:wx:yz”. For all I know it’s trying to link to one of the 6 other WiFi networks that my PC can see!

So I searched the documents and this forum, and there was the tantalizing possibility of connecting via USB/Ethernet, but although my Reach has an Intel Edison, the Windows 10 Device Manager thinks it’s CDC ECM, and it says “There are no compatible drivers for this device.”, and a search does not find any. If it had been RNDIS, I guess this would have worked: https://software.intel.com/en-us/connecting-to-intel-edison-board-using-ethernet-over-usb

I tried running the Segger IP-over-USB trial software, but that had no effect.

Can anyone persuade me not to put this dear little thing into the waste basket?

Hello,

I did take the laptop and Reach outside and it managed to show the green light then. But still no hotspot / white light / reach:wx:yz WiFi in my WiFi list :frowning:

Reach probably is still in the range of your temporary Wi-Fi router and works in client mode.

To find its IP you’ll need Android or iOS mobile device connected to the same Wi-Fi network and running ReachView app.

Or you can turn off your router and reboot Reach. It should start in hotspot mode.

The router has been switched off for some time now. I took the Reach outside the building and that’s when it cycled between blue flashing and green every three seconds (instead of blue flashing and magenta inside the building). I went out again just now, and it did the same thing. Still no WiFi hotspot. I waited at least 3 minutes.

I don’t know if this is relevant, but:

(a) Last week I did have the office’s guest network configured in it, but the network’s IP address was 192.168.42.xx, and I wasn’t able to find the Reach on it (the guest network is big and doesn’t like being nmap’d!) so I removed that by going to my other office and configuring the guest network there (which is 10.50…), and removing the first guest network via the Reach’s web page. That worked OK, and I was able to update the software there.

(b) My other office’s guest WiFi network is still configured in the Reach. I think I’ll go over there and see if it will connect with that again.

:frowning: My Reach is now not connecting with my other office’s WiFi - I’ve checked on the IP address allocation list. I have it near a window, and it’s cycling through flashing blue (network scan) and steady green (app running) every three seconds.

Any suggestions?

I have just tried the Emlid Reach RTK at home, where there are only two WiFi routers visible, neither of which has been seen by the device before. It still refuses to go to hotspot mode, even though it has satellite visibility.

The trash can / wastebasket beckons!

Unless you have any critical data on it, i would do a reflash by now.
https://docs.emlid.com/reach/common/reachview/firmware-reflashing/

1 Like

Also, please take a look at this part of the documentation:
https://docs.emlid.com/reach/led-status/

If you eventually decide to reflash the unit, please use Terminal guide

2 Likes

Many thanks for the useful links.

Managed to install the USB drivers, but when attempting to flash the device, I got this:

Failed to process component: Install image
Integrity checking failed
Source file is incorrect
iot-devkit-prof-dev-image-edison-20160315.zip

Click ‘Continue’ to ignore error and install other components or ‘Cancel’ to cancel installation and rollback changes.

I’m reluctant to move on! What do you think I should do, TB_RTK and Dmitri?

Looking at the Windows 10 device manager, I see I now have a Network adapter called
Intel Edison USB RNDIS Device, with an orange triangle and exclamation mark against it. In the properties I see:

This device cannot start. (Code 10)

{Operation Failed}
The requested operation was unsuccessful.

Are you following the teminal guide or GUI guide?

If GUI, then you should follow the Temporary GUI workaround

I’ve just realised, Dmitri said use the terminal guide. I’ll do that when I next have a spare moment. I was using the GUI.

1 Like

:grinning: Found some time at last, and reflashed using the terminal instructions for Windows. My Emlid Reach now works as advertised: it publishes the hotspot so I can access the HTTP home page and ssh into it as root with the standard password (full name in lower case without spaces).

Thank you so much for your help.

2 Likes

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.