Reach RS2 with DJI M300 and P1 Payload-PPK possibility?

Redcatch will allow average base position, Rinex header, and manual input.

That’s good news. I also have the M300 P1 RTK2 base combo and looking for solutions. I assume you did have the RTK2 connected to the M300 while collecting data from the RS2?

No, no DJI RTK base is needed. Set up the Emlid RS2 before starting the drone operation. If you have a known point, set it up on top of that. Start the RS2 recording logs before drone takeoff, and make sure it records during the flights and don’t stop it until after your last flight is completed. The M300 drone records it’s own logs and using a software like RedCatch, you can PPK (post process) the drone’s photo exif data. In RedCatch, you have to import the photos, the RS2 logs and the M300 logs.

1 Like

Hi everyone,

I’d like to add a few words. You can use both RTK2 and Reach RS2 as a base for the DJI M300. A good note is that you should record the log on the base during the whole flight of the drone and that you need to place the base on a known point.

As for PPK, you can use the free beta version of Emlid Studio - our desktop application for post-processing. We have detailed guides on how to work with it, and we are always ready to help you if you face any difficulties.

Hi Elena, Trying out the Emlid Studio beta version and the number of time stamps doesn’t match the number of photos. What would cause that? I’m using beta 10.
I guess I should mention I’m using CORS file for the base station not the RS2. Just trying to work through some flows right now.
Thanks

Hi Joe,

What is the current receiver firmware version, and what Emlid Studio version do you use? We have encountered a similar problem before. However, we released Reach Firmware 27.1, which includes the fix of the issue with missing time marks in August. We also fixed this in Emlid Studio.

Hi Elena,
I’m running v 27.1 on the RS2 and not sure what version of the studio just say Beta 10. OK maybe why this isn’t working for me. My rover file is coming from the M300 and the base is coming from the CORS network not from the RS2. I’m flying another site today with the RS2 set as my base so may give it another shot with that.
Thanks for the response.

Hi Joe,

Thanks for your clarification! It all makes sense now. The thing is that Emlid Studio can currently post-process only time marks recorded directly into the raw data log. However, DJI drones record them in a separate file, so our software just doesn’t find time marks in a log.

We understand that we have many users who can work with DJI drones, so I’ll be sure to note this as a future request.

I have some questions Elena. I’m using the the M300 with the RTK2 and the RS+ to record my GCPs. I have used the RS+ with NTRIP to record a known point. I use this point and input the coordinates in the advanced RTK settings of the Pilot app. When finished mapping I have 4 files on the SD card in the P1 camera. They are Timestamp.MRK, PPKRAW.bin, PPKOBS.obs, and PPKNAV.nav. I’m having trouble trying to use the workflow in REDcatch. I’m working with them now and they seem very helpful. We are sending them a dataset with all my RS+ GCP information and they are going to look at it. Do I need to be logging anything in the RS+ while I’m flying. I guess I’m missing something.

Hi @cmsauls,

Do you have issues with GCPs from Reach RS+?

I haven’t had a chance to work with REDcatch software. So, I’m not an expert here. But in general, if you use Reach RS+ for GCPs, you don’t need anything but CSV with points coordinates.

1 Like

Yes and NO. I can use the RS+ to get cm and sometimes sub cm readings. I have no issue exporting the CSV file and importing them into the Agisoft software. The only thing that I am having issues with is that the GCP locations are sometimes 10 to 15 meters above ground or at least above the map. The lat and long positions are 99%+ accurate. After doing a test several days ago I did get the GCPs to show about 99% accurate elevations although I’m not sure what I did to achieve this. I was using the same system and settings as a map several days before but with a completely different outcome. I know that the RTK2 records coordinates in WSG84. My NTRIP service provider uses NAD83(2011). There are several vertical datum options that I can use and have tried all of them. I guess there is some setting in Agisoft that I haven’t found yet but I have tried several relating to the coordinate systems including the one in Agisoft where you can use the coordinate system that you used for the GCPs. I think my biggest question is how the two coordinate systems interact with each other and IF they are not syncing with each other then which one do I believe? Is the map too low or are the GCPs too high? The software you can manually adjust the GCP coordinates but that doesn’t seem right. ALSO, I sent a small dataset to REdcatch and I was asked to also send the base station data. All I have is the files that the P1 records and the CVS file from the RS+ for the GCPs. Not sure what he wants. Thanks for your reply.

1 Like

The guys at REDcatch advised that I don’t need their software workflow using the RTK2 BUT they suggested using the RS+ to get better more accurate coordinates and insert those into the RTK2 advanced settings. I just have to figure out why my GCPs are off. I’ll continue to work on it.

Question…If you use the Emlid to measure your known point that the RTK2 will be positioned on, do you want to avoid correcting for pole height using the Reach View 3 app? I think that DJI corrects for their pole height assuming you are using the pole that comes with the RTK2. I wonder how the two interact. It seems like you would NOT use the pole height correction in Reach View 3. You would measure the height of the RTK2 and just add that pole height to the Emlid measurement.

Hi @cmsauls,

Such elevation difference usually means that you use ellipsoidal heights when you need orthometric ones (heights above geoid). For example, you collect points with Reach RS+ with ellipsoidal heights, while Agisoft uses the Global geoid by default.

If you share your ReachView 3 and Agisoft coordinate system project settings, I’ll be able to say something for sure.

UPD. Fixed the typo

Hi @contact,

If you measure a point with Reach, you receive a coordinate of the point on the ground in CSV. That’s why you need the pole height correction in ReachView 3. If you don’t use it, you’ll obtain the antenna phase center coordinates.

Thank you very much. I think you are on the right track. I’ll try to get you some information soon. In the last test, the GCPs were all very close but Agisoft was saying that some of the coordinates were off as much as 10 to 20 meters. Obviously, there are some conflicts that I have not figured out yet but I’m sure with your help we can resolve the issue. Thank you again. I’ll get you some info very soon.

1 Like

I just flew a mission today with the M300 RTK and was receiving correction. When i check my files on the SD card, I don’t have .mrk file or a .bin file… How can i get these files?

Sorry for the delay. I wanted to shoot several more test maps. I did a test measuring multiple GCP coordinates using NAD83. There were 6 different measurements in all. After looking at the CSV files it was clear that there was very little difference between all 6 GCPs, in most cases, sub-cm which included lat, long, and elevation. I feel the Emlid data is very solid. I then completed 3 maps of the same area. The first map was using the RTK2 with factory “out of the box” settings. Then I shot the next map using a custom network with NTRIP and the last map used a known point measured with the Emlid with pole height corrections. After getting the Emlid measurement I then added the RTK2 antenna height to the Emlid measurement and interred that measurement in the custom settings. When I bring all the data in Agisoft using the WGS84 all the GCPs are where they are supposed to be with acceptable errors but when I change the project settings or use the coordinate system used on the GCPs they float off hundreds of yards away or the angles of the maps change. I have tried converting the coordinates on the pictures but nothing is helping. I feel like my workflow is not right but I have tried multiple combinations and still lost. I would be happy to send you a link and share with you all the data including the pictures or I could share some specific screenshots. How do you want to handle this data? Thanks for your help.

@cmsauls,

You mentioned you processed three maps with different base settings, right? Were they all processed using GCPs?

I would like to check the screenshots of your Agisoft projects’ settings and final maps.

You’re right, it’s indeed quite hard to find the possible reasons without checking the data. I suppose it’s sensitive, so you email us at support@emlid.com.

Thank you. Yes, All maps were processed with GCPs. The three datasets were captured with the M300, P1, RTK2 and each dataset was processed using several of the RS+ CSV files. I’ll get you some information shortly.

1 Like