Reach RS2 WiFi Connection with Android

Hi there,
We have a Reach RS2 which we want to be able to use for both GIS mapping (using Collector for ArcGIS) and normal GNSS surveying (detail surveys, etc). So far we have been able to use it with iPad/iPhone as controllers but these are not ideal in terms of our workflow/software/app requirements. We require it to work on an Android tablet.
As such, we have purchased a cheap’ish tablet - Samsung Galaxy Tab A 8" WiFi 32GB (2019).

The tablet is probably not the ultimate ideal machine to use, but we thought that it would do the job in terms of evaluating Android as a platform to use with the RS2. However, we cannot get it to hold a connection to the RS2’s WiFi hotspot. Bluetooth is fine but we require the WiFi hotspot in order to access the internet connection from the receiver (for Collector for ArcGIS Online)

The iPad, iPhone and Windows 10 laptop have no issue - they connect and hold the connection no problem to the reach:AD:6B hotspot. But as the RS2 is not certified by Apple to allow it to be used as a location source, we cannot use it with an iOS device for Collector.

The tablet will either not connect or will not hold the WiFi connection. The hotspot shows up in the available WiFi list on the tablet, but we are unable to connect to it reliably. If it does connect, it holds the connection for approximately 15-20 seconds then drops it and won’t reconnect.

The RS2 has the latest firmware on it (2.22.3) and the tablet is running Android 9.
We have also tried to connect to the RS2 with other Android devices as follows:

HTC One m8 phone running Android 6 - Same problem as tablet.
Sony Xperia XZ Premium phone running Android 9 - Same problem as tablet.
Samsung Galaxy Note 9 running Android 10 - connected and held the connection no problem.

Has anyone had similar issues or any ideas how to fix the problem. I’m not sure what other information may be required to assist with this, but please let me know if you need more info. Happy to provide and all help appreciated.



Hi Ben,

You mentioned that you need to provide your devices with an Internet connection. Do I understand right that a SIM card is inserted into Reach RS2 for it?

I need to understand the whole hardware setup to check what might cause such an issue.

Hi Anastasiia,
Yes that is correct. The SIM card is in the RS2. We also use the SIM card internet connection for RTCM correction via NTRIP. this is functioning perfectly fine.
Thanks for your help. Let me know if you need more information.

Thanks for the details!

May I ask you to remove the SIM card from the Reach RS2 and try connecting an Android device to the RS2 hotspot? Please let me know if it changes anything.

Hi Anastasiia,
I removed the SIM card and tested the connection again… Works perfectly! The tablet connects and holds the WiFi connection no problem (same with the other Android devices).

I have now turned off the RS2, put the SIM card back in, turned it back on and tried the WiFi connection again… No good! Tablet and Android devices dropping connection and not reconnecting. I will try another SIM card to see if that’s the issue, but I suspect not. Any ideas your end?

Thanks again for your help.


So I tried a different SIM card and interestingly, it worked… kind of!

The tablet and other devices connected to the RS2 over WiFi and held the connection. But there was no internet.

The SIM cards are both with the same network provider (Telstra) in Australia. Neither of the SIM cards are locked in any way. They don’t have any PIN on them. They both have plenty of data available to them. The second card is from my own mobile phone (an iPhone).

Is there any more in formation I can provide to you that might help?



Hi Ben,

Thanks for the tests’ results!

In the meantime, we’re working on fixing the issue with a hotspot mode when the SIM card is inserted. I will inform you when the version with a fix is released.

Let me suggest a temporary workaround.

You can insert the SIM card to your Android phone and configure the access point there, so Reach RS2 can connect to this WiFi network. It is possible to obtain corrections over the NTRIP service as you’ve done before.

Hi Anastasiia,
Thank you for the update.

We will try your workaround and hopefully a fix for this is not too far away. Do you have any idea on a timeframe for this fix to be ready?

Many thanks,


Hi Ben,

I’m afraid, I can’t provide you with any exact timelines at the moment. We are doing our best to release the fix as soon as possible, but in the meantime, there’s no ETA, unfortunately.

I will keep you posted. Thanks!

Hi Anastasiia,
No problem. Very much appreciate your help and glad to see Emlid are pro-active about these things.

Look forward to hearing from you and the new release.

Best regards,



Hi Ben,

We have fixed the issue with hotspot mode when the SIM card is inserted in the v2.23.4 dev release. It’d be nice if you’ll be able to test it to check if the hotspot with the inserted SIM card works as expected.

Please note, it is currently not possible to share mobile data over Wi-Fi to a phone/tablet in this version.

Please note that dev versions are mostly used for testing purposes and not intended for use for real field projects. Also, once you update to the dev version, returning to the stable release will require the reflashing of the unit.

This fix will make it into the stable branch in one of the next updates, so you can wait until we push the stable to check if it resolves the issue.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.