Reach RS2 problems connecting to WIFI via router

I have just recently purchased Reach RS2 Base and Rover units. They connect to my Android phone network when used as a hotspot with no problems, but they can’t connect to my Home Wifi router via a router. I have updated both units to the latest firmware. The Reachview 3 app on my phone when connected with RS2 hotspot, also doesn’t see my home Wifi as an available network. All other devices I am using do.

What are the settings that I should be changing on my router in order to allow them to connect? The router is a NetComm NL1901ACV 4g using sim for internet. My network does not appear on the available Networks list and entering the details into the hidden network option doesn’t do anything.

Please can someone shed some light on this subject as it’s hard to get started here.


Hi Phil,

Could you please specify the frequency that you’re Wi-Fi router is working on? Reach RS2 is capable of connecting only to the networks on 2.4GHz.

Oh, sorry forgot to say 2.4GHz. I did read that they only connect to this frequency


Thanks for the specification!

Do I understand correctly that Reach can connect to other networks without any issues? Does the SIM you use for the Internet support other technologies like 3G and 2G?

Hi Polina,

I have solved my problem thankyou. I was able to connect to other networks on a few different mobile phones hot spotting, but I wasn’t seeing my home wifi at all. I tried another modem (non 4G) and it connected. As that one only works with ADSL, I need sim to connect to internet. So, I reset my NetComm back to factory settings and just left the default SSID and password and I now have success.


Thanks for sharing an update! Great to know you can use your Reach RS2 with home Wi-Fi :slight_smile:

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.