Reach RS2, Post Processing Static Base in Leica Geo Office

Hello!

My Leica Geo Office fails to Post Process RINEX data coming from Reach RS2.
I used Emlid Studio 1, Beta 10 to convert raw UBX files to RINEX 2.11 and 3.02, selected RS2 as the receiver and indicated the measured height (1.210m).

I can successfully import the RINEX data into LGO, but when I run static post-processing it resolves to Float with L1 only.

LGO Antenna Parameters

Most of the Antennas in LGO have Elevation and Azimuth correction parameters. Are there any for Reach RS2?

Please, help.

Hi, @Vusal ! This is a recurring question here in Brazil as well.

The RS2 receiver antenna only tracks L2C and not both L2C and L2P, this information is in their catalogue. LGO, by its “age”, only recognizes the L2P band.

Therefore, only the L1 band is processed in LGO or any older software, such as TopconTools or GNSS Solutions, for example.

2 Likes

Thank you for your prompt response, @pedroaugustofaria!

Are there any alternatives to the “oldy” LGO to post-process Reach RS2 data?

1 Like

In addition to Emlid Studio, newer post-processing software will recognize the L2C band, such as Leica Infinity, MagneticTools, among others. I personally have never used these software to post-process RS2 data, so my suggestion is only technical.

Hi there,

Pedro, I learned from your answer as well! Thank you.

@Vusal, did you have only GPS constellation enabled? I think there is a chance to achieve a Fix even if there are no GPS L2P signals.

1 Like

Same situation with Leica Infinity :frowning:

I cannot get Fix with GPS+GLONAS L1 :frowning:

Have you tried to process your logs in Emlid Studio?

1 Like

:grimacing:

Does your Infinity have an active L2C band processing license? It could be something related to that. The Leica Infinity that we have in our company is a complete demonstrative license, which carried out the L2C import properly. Have not tested with Topcon MagneticTools.


Furthermore, I suggest that you perform a test with Emlid Studio. It is free, based on open source, compatible with Emlid’s GNSS solutions and without these paid limitations…

Yes, I did and it resolved to Fixed.

Managed to get a Phase Fix solution in Infinity with GPS/Galileo/Beidou, but only L1/E1/B1/E5b.
I cannot verify if there is a separate license for L2C band.

I can get Fix L2 in Emlid Studio, but it does not allow performing Network and Loop Adjustments.

The following warning message comes up after processing is finished: Missing orbits for satellite G22, R11, E20, E30, C10

Besides, I can see inside Infitiy that RINEX data contains all the necessary GNSS data except for L2:

LGO Infinity 1
LGO Infinity 2

The strange part with Infinity is that it does show the L2 Signal, but it does not use it for computing.

Strange. I don’t know what could have happened anymore either.

Is this strictly necessary? I ask because I don’t know your workflow or the agencies you need to report data to.

Could you please confirm if this settings is true to Reach RS2:

LGO Infinity 4

I have indicated a vertical phase center offset 0.1370m for GPS L2
Should I do the same for ALL Satellites, like GLONASS, Galileo, etc.?

Was is the Elevation and Azimuth Interval for Reach RS2?
Btw, are there any corrections to be setup for Azimuth?

I have confirmed that Leica Infinity does support L2C signal, but for some unknown reasons it fails with the one coming from Reach RS2 :frowning:

1 Like

In this case the calibration is GPS only, not multi-constellation. But it doesn’t vary much, it’s not a reason to cause big differences in measurement or loss of accuracy.

Hi @Vusal,

Usually, if you add the antenna name or ATX file, all the parameters should be filled in automatically. Does Leica Infinity support that? It’s just the best way to fill them in correctly.

However, here’s the ATX file. We have antenna calibration details for GPS L1/L2 and GLONASS L1/L2. If you search “EML_REACH_RS2” in this doc, you’ll find North, East, and Up values for each frequency.

Both Elevation and Azimuth intervals are 5º.

If correcting the antenna parameters doesn’t help, I’d suggest clarifying with Leica support if they have additional requirements for L2 frequencies. We’re always ready to make our logs compatible with other software.

1 Like

Successfully imported the ATX file. Now I can see EML_REACH_RS2.
Still no luck with L2.

1 Like

I can get a 100% FIX Solution with Emlid Studio, but unfortunately it does not generate any processing report to show what satellites and frequencies were actually used for the computation. The result is just a .pos file.

Besides, the biggest disadvantage with Emlid Studio is inability to post-process the same point from 2 base stations and average/adjust the final result based on 2 baselines.

1 Like

I got your point about network adjustment and baseline processing. But why do you need such a detailed report? I’m asking because we may think about adding this data to output, but we need to understand the application fully.

Regarding the Leica Infinity processing issue, it seems they have other requirements for L2 frequencies. As I said above, it’s better to ask their support what’s going on. If they find the cause of this incompatibility, please let us know.

1 Like

We need to prove to our clients that we do implement Quality Control and Quality Assurance while reporting accuracy figures. There is no way of control with a single baseline.

Both Leica Geo Office and Infinity provide Summary and Detailed Reports of all the processing. This ensures confidence and proof of work.

3 Likes