Reach RS2 hard reset

Is there any way to do a hard reset if I can not connect to my RS2 with wifi of any kind? I can not use the hotspot because it is not the default emlidreach password, I can not use Reach Firmware tool in Windows or Linux and I have tried on the 5 computers that I own with many different USB cables. I can connect but the flash always fails. I had this problem when I bought my first 2 RS2 units I think it is my bios is too old because I have a lot of legacy software for my GPS and GPR equipment. I also tried the over 15 second power button hold and that did not work. I got this Reach 2nd hand so I need to wipe it clean. Thanks

Hi @brycethomaskennedy,

Welcome back to the forum! We recommend flashing to bring the Reach back to its initial state, but it can fail if there’s some issue with the unit.

  • What is the Network and Battery LED status?
  • What happens when you connect to the Reach hotspot with a new password?
  • Did something unusual happen before the Reach started to behave this way?

UPD. Changed the second question.

1 Like

I bought this one used and have never connected to it, battery is full, since whatever network it has used in the past is not present it defaults to hotspot, I enter emlidreach it says “authorizing” then rejects the password and does not let me connect. I think I need to find a newer computer to attempt the flashing . My newest is 5 years old.

Here is the log file when it fails

06:44:59 - - INFO - progress: 100

06:45:29 - - INFO - gRPC initialize() finished. Shutdown server…
06:45:29 - - INFO - gPRC ShutDown() call
06:45:29 - - INFO - Server has been terminated
06:45:29 - - INFO - Job error: Can’t find device on 2-1 port
06:45:29 - - INFO - Initializer was stopped

I see; thank you for explaining the issue. Can you send full failure logs from the Flash Tool from both Windows and Linux devices? You can send them to or use WeTransfer. I want to take a look at them.


No Need to put any energy into this, I used a friends computer with the blue usb ports and it flashed right away first try so my 2.0 usb ports are the problem. Up and running though


Thank you for updating us! I’m glad to hear you’ve figured it out.

1 Like