Reach RS2 failed update - stuck on startup

I have 2 new Reach RS2 and have followed the prompts to update the ReachView 26.0. Test, WiFi, TimeSync are good and the ReachView 26.0 progress bar is full and green but still shows the loading on the ReachView Update tab.

I have let it sit here for over an hour.

On the second unit, I went ahead and pressed the Reboot and Go to the App button. And on this unit the RS2 fails to start. The progress LED flash sequence never stops. I have tried near my WiFI and the indicator goes blue but progress bars LED flash does not stop. I have also shut down my WiFI to force the RS2 to not connect to local network. The only difference is the WiFi indicator stays white but the 5 LED progress lights keep flashing. I have now let it try starting for over 12 hours and still no change.

I don’t want 2 dead RS2! Does anyone know how to get these systems to boot and update properly?

1 Like

I just had the same issue with my RS2, and posted a similar thread for help today. No responses yet.


I hope we can get some answers soon. Would be nice to have a way to factory reset the system.

1 Like

Hi Harrison,

How far this device is located from the router? In some cases, the distance can affect the updating process.

Please text us at with the following info:

  • the Serial Number of the device (you can scan QR code under the SIM card slot)
  • order date and number

We’ll check what we can do with this unit further to make it work.

1 Like


Is it possible to access the update page (Reach_IP_address:5000)? If yes, could you check whether Reach fails any tests and send the screenshot of it to us?

1 Like

Yes, I am able to connect to the update page :5000 and the test 8 failed all others have green check marks

What should I do?

1 Like

Contact Emlid support directly would be your best option.

Hi Harrison,

Yes, further troubleshooting may require sensitive info from you. So, please contact us at specifying that the unit fails Test 8. Also, please share the Serial number of your device. For this, you need to scan the QR code under the SIM card slot cover.

1 Like

Thank you! I just sent an email from my ROCK robotic email. Harrison

1 Like

Thanks! I’ve just received your email and answered you there.

Was this resolved? I am facing the exact same issue on my new RS2. Failed Test 8 etc…

It worked yesterday and I got into Reachview.

Now today can’t find it through Reachview. The white LEDs keep flashing. WiFi light solid blue.

I can get back to the Updater page through IP:5000. Now it bounces between connectivity when trying to update (which I thought it already did yesterday before getting into Reachview).

Hi @RTK_Hunter,

Please email us at with the serial number of your unit. Tests failing may be related to different reasons, so we need to investigate each case separately.

1 Like

I just sent over an email to support. Thanks.

1 Like

I reflashed the unit. It struggled a few times as kept getting hung up. I tried over 5 times and it finally went through the last round and seems to be fully functional now. Time to play now :sunglasses:

Hmm, interesting. Probably, some firmware components were installed incorrectly at first. I suppose there should be no issues with the unit now. Still, if you notice something, let me know.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.