REACH RS2 : Can't connect to my router anymore

Hello EMLID Community,

I have for my drone mapping, a Reach RS2 and a reach M2. I connected them to my router and link them successfully as base and rover as mentioned in the documentation.

For some reasons now, they don’t connect to the router anymore. Worse, they don’t even detect it when I go on “Wi-Fi” tab on ReachView3. All my other devices are fine and detect my 3 networks (2.4 Ghz and two 5Ghz) . I have another Reach M2 and it has the same problem. So it isn’t happening with just one special device. Also I can easily connect the RS2 and M2 to other networks, so it seems that for some reasons, connecting to my router ( NETGEAR Nighthawk R8000P ) is really not working right now.

I tried to reset the router : no success.

What could be the problem ?

1 Like

Hi @kefran88,

Welcome to the community forum!

Do I get it correctly that your Reach receiver doesn’t connect to the 2.4GHz network? Can you please double-check that the 5GHz and 2.4GHz networks have different names? Reach receivers don’t work with 5GHz networks which is why they might not be able to connect to the known network with two different frequencies.

Hello @polina.buriak,

I turned off the 5GHz network and still have the same problem… My other devices still detects it but not the EMLID ones. I bought another router to see and the devices detect the 2.4 GHz network easily . I think the problem comes from the EMLID devices since they were able to connect to it once

I had a similar issue about one month ago trying to update to the latest DEV version. One of my RS2 units connected to my local router just fine, but the other could not. It showed having a connection, but I was not able to update the software. What I did was to temporarily disable 5GHz network (which you seem to have done already), but also to forget the RS2 unit (by IP Address) from the router settings as well. After this I was able to reestablish a connection between the RS2 and the local router.

Hey @kefran88 and @lucas,

Reach devices do indeed work with 2.4 GHz networks only. That’s why it gets tricky when networks on both frequencies (2.4 GHz and 5 GHz) have the same name. So Reach needs to see only 2.4 GHz frequency for the connection.

@kefran88, could you please specify after what actions the connection to your network started to fail? Did you update the units to the latest beta version?

Hello Polina,

Sorry for the delay.

I already tried what Lucas mentionned before since I reset my router once and even manually forgot the IP adresses. I bought a new router and it solved my problem. But yesterday,My Reach M2 reconnected itsellf to the 2.4Ghz network of the previous router… I won’t say the issue is solved since I don’t know why this happened in the first place.

@polina.buriak what I did before the network started to fail what assigning IP adress to each of my EMLID devices. But I doubt this could be the problem, I did it on my new router and everything works perfectly

Best regards

Hi @kefran88,

Thanks for the update and sorry for the delay!

Currently, it’s hard to specify what could be the issue here with the router. As I’ve mentioned, Reach receivers are capable of working with 2.4 GHz networks only which is why they can be confused when both networks on 2.4 GHz and 5 GHz had the same SSID names. The assigning of the IP addresses might have led to such issues if it had been configured in the incorrect network only.

Usually, the restart of the router after applying changes should solve the issues. Unfortunately, there’s no way to check this from the Reach device.

Meanwhile, please, keep your 2.4 GHz and 5 GHz networks with separate SSID names and passwords so that Reach can connect to the 2.4 GHz networks. To make Reach connect to one network all the time, you can delete all other known networks. If there are many known connections, Reach will connect to the network with the stronger signal.

If you have the same issues further on, please, reach out to with the Full System Report from your device. This report contains sensitive information about your connections which is why it’s advisable not to share it publicly. After checking the report, we’ll be able to determine if there’s any specific reason why Reach struggles to connect to the network.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.