Reach RS+ won't charge or turn on

We’ve got two Reach RS+ units. One used as a base, one as a rover. They were used in the field a couple of weeks ago without any issues, the data was downloaded, and then the units packed away. The ‘base’ unit will now not turn on.
Yesterday I plugged it into a microUSB to charge, but no blinking orange light. I tried to turn it on, but nothing, no lights at all. I tried the cable on the other RS+ unit and it immediately started blinking orange to indicate it is charging, so I don’t think there is an issue with the charger or cable. I have also tested another cable and charger, and got the same response.

I left the ‘base’ plugged in overnight hoping the extended period might somehow bring it back to life. Today the orange light has started blinking, but i still cannot get the unit to turn on.
If i hold down the power button the other lights (NET and STAT) light up, but go off as soon as i release the power button.
Both units are about 1 year old and only used occasionally.

Hi @ecw,

Could you please check my message in the PM? At this stage, the troubleshooting might require some additional actions which will be easier to handle in private messages.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.