Reach RS will not start

I have a Reach RS that was purchased in 2018 and will not start.

This device is used on tractor for guidance and is usually charged via the bottom port when the tractor was running.
When pressing start button the lights flashed and then turned off and it would not restart. I initially thought that the battery had gone flat overtime so I tried recharging via the USB port with several different usb power sources and the bottom port directly connected to a 12v

battery. The RS2 will still not start.

On opening the case I found droplets of water inside on the grey top and also in side the black body of the case. I have waited for these to dry out but it still does not start. I have tried measuring the voltage from the battery but the terminals on the plug are very small and difficult to position probes but the battery would appear to be flat now and has not held charge.

Does anybody have any experience with this situation and can recommend any diagnostic steps
to verify what the cause of the problem is.

thank you


Hi Graham,

Do I get it correctly that neither of your RS+ and RS2 devices turns on after the survey? What kind of setups were they used in?

Please provide this information to us over our support email Also, please share the serial numbers of all affected devices. You can check how to find them out in our guides for RS+ and for RS2 respectfully. Further troubleshooting may require sensitive info from you. That’s why it’s better not to share it publicly.

Also, please don’t disassemble your devices. It voids the warranty as we can’t ensure all of the hardware components are intact after the disassembly. If you have any doubts about your unit’s performance, please contact us first at or here on the forum. We’ll definitely help you to solve the issues you face.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.