Reach RS+ WiFi issues - 14-04-2022

Hi there everyone! I have received a replacement RS+ unit because of some hardware issues, which is GREATLY appreciated! Yay Emlid for having AMAZING customer service. Today I decided to put some time in and hopefull map our land. Sadly I have run into wifi connection problems with the unit that was working and that I owned from before. It is unable to go through the ‘updater’ program which is prompted when you first boot it and it recognizes it needs a firmware update.

  1. Firmware image and ReachView version.
    Firmware I don’t know as I don’t get passed the wifi login option
    Reachview 3 version is 6.17 (latest, i checked)

  2. [System report]
    Same as number 1.

  3. Detailed problem description. How does observed behavior differ from the expected one?
    I have a Reach RS+ unit that I want to connect to my local wifi in order to do a firmware update. It doesn’t seem to be able to connect at all. As soon as I enter the wifi and password it gives me a specific message and quits the ‘updater’ program. I have written down the whole message below at 11:14. I should mention that 5 minutes after the log below I managed to update the new unit without issues.

  4. Your step by step actions.

These are timestamps :slight_smile:

11:05 Started up the rover unit. Connected, its called reach-rover. It is telling me to connect to the wifi in order to update the firmware. I have it saved from the last time I used the unit. I connect it and switch back to our wifi.

11:08 It doesnt connect to the saved wifi. Will delete it and try to re-enter

11:11 Three tries and the rover doesn’t accept the wifi. When I enter it, it starts blinking the blue led but then returns to a steady blue led.

11:14 it says ‘Reach is connecting to another network. Switch to [network name] to continue.’ It automatically switches me but the rover doesn’t connect and continue with the update.

11:16 one more try, will try the ‘test’ button first.

11:16 it does the tests automatically and all 7 tests are fine.

11:17 tried switching the security protocol to WPA PSK instead of WPA PSK2

11:20 it still doesnt switch to client mode

11:21 turning off the rover for now, going to set up the base

  1. Picture of the setup and connection scheme.
    https://photos.app.goo.gl/y72Fhr7uW7yApsv9A
    The last image is the last thing I see before having to reconnect to the unit’s hotspot and try anything else. It simply refuses to go on from there.

  2. If using any additional hardware please provide exact make and model.
    No hardware issues. Battery is fine, startup is fine, no damages, nothing.

Any help would be greatly appreciated.

Kind regards,
Bram

Hi Bram,

Thanks a lot for your warm words! We appreciate them so much :smiling_face:

Thank you for the screencast as well. It’ll help us to check it out.

You’ve mentioned that you have a base and rover. Which of them have you managed to connect to Wi-Fi and update?

The first screenshot from the screencast shows that you’ve connected the phone to local Wi-Fi. Then, you set up Reach on the Updater page. It could be possible only if Reach is connected to the same local network, but it’s not. Or is this screenshot made right after you exited from Updater and tried to connect to Wi-Fi?

Your local Wi-Fi should work at the 2.4 GHz band. Please check if it is so, or it doesn’t work at 2.4 and 5 Hz either. There also can be a firewall or a limit of connections’ number. Can any another devices except for the phone connect to local Wi-Fi?

I’d also suggest you connect Reach to the mobile hotspot. It’ll help us understand whether this issue is related to Reach or local Wi-FI.

Hi there Kirill,

I am glad to give the compliments and they are truly heartfelt. Still glad to have gone with Emlid as the support has been amazing so far.

So I managed to connect to another phone’s hotspot with the unit and update it. After that I could operate them normally. However I have been unable to take any good readings. I will post what I tried here and then add two system reports of the settings I have going right now. Will add more pictures to the photo album as well.

12:00
Followed the advice on the forums and connected to a wifi hotspot from a mobile phone. That worked and I updated the firmware of the Rover that didn’t work last time.

12:09
Continued to follow the guide mentioned all the way in the beginning, which led me to the next page of setting up base and rover. Followed those instructions.
https://docs.emlid.com/reachrs/quickstart/base-rover-setup

12:20 Followed that guide but got no Corrections in the Status screen on Rover

12:21
Checked both settings again and Rover has Glonass AR mode ON, and Base is OFF. I will turn Base to ON because Rover worked before.

12:23 Still no corrections. I will try the opposite.

12:34 Tried to turn rover into hotspot as I noticed it was still connected to the wifi

12:36 that didn’t do anything until I realized base needs to be in the same mode. doing that now

37 both units show up in wifi, connecting to rover

37 it still says connected without internet but I can connect to the unit no problem

38 still no corrections damnit

56 played around trying to get that to work but nothing. took both units out of hotspot mode and am going to try to switch to beidoou

13:03 I realized that the rover didn’t update correctly and was still in version 26.6. updating now to 28.4.

13:10
The connection issues persist. Going to post the settings to the forums

Rover:

Simple system report
app version: 28.4-r0
current_network:
  ip: 192.168.43.24
  security: wpa-psk
  ssid: micha
enabled: true
mode: client
base_mode:
  base_coordinates:
    accumulation: 120
    mode: single-and-hold
  output:
    io_type: lora
    settings:
      cloud:
        mount_point: ''
      lora:
        air_rate: 9.11
        frequency: 868000
        output_power: 20
      ntripcaster:
        mount_point: REACH
        password: '***'
        port: 2101
        username: reach
      ntripsvr:
        address: ''
        mount_point: ''
        password: '***'
        port: -1
      serial:
        baud_rate: 38400
        device: ttyEXTS0
      tcpcli:
        address: localhost
        port: 9001
      tcpsvr:
        port: 9000
  rtcm3_messages:
    message_1002:
      enabled: true
      frequency: 1
    message_1006:
      enabled: true
      frequency: 0.1
    message_1010:
      enabled: true
      frequency: 1
    message_1097:
      enabled: false
      frequency: 1
    message_1107:
      enabled: false
      frequency: 1
    message_1117:
      enabled: false
      frequency: 1
    message_1127:
      enabled: false
      frequency: 1
bluetooth:
  enabled: false
  pairing:
    discoverable: false
    no_input_no_output: false
    pin: '***'
correction_input:
  base_corrections:
    io_type: serial
    settings:
      bluetooth:
        send_position_to_base: false
      cloud:
        mount_point: ''
        send_position_to_base: true
      lora:
        air_rate: 2.6
        frequency: 868000
        output_power: 20
        send_position_to_base: false
      ntripcli:
        address: ''
        mount_point: ''
        password: '***'
        port: -1
        send_position_to_base: true
        username: ''
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        send_position_to_base: false
      tcpcli:
        address: localhost
        port: 10001
        send_position_to_base: true
      tcpsvr:
        port: 10000
        send_position_to_base: true
device:
  power_on_bottom_connector: false
  privacy_policy_accepted: true
  role: null
  rv3_banner_shown: false
  usage_analysis_accepted: true
logging:
  logs:
    base:
      autostart: false
      format: RTCM3
      started: true
    raw:
      autostart: false
      format: UBX
      rinex_options:
        logging_interval: 1
        marker_name: null
        pole_height: null
        preset: custom
        satellite_systems:
          beidou: false
          galileo: false
          glonass: true
          gps: true
          qzss: false
          sbas: false
        time_adjustments_enabled: false
      started: true
    solution:
      autostart: false
      format: LLH
      started: true
  settings:
    debug: false
    interval: 24
    overwrite: true
    simultaneous_logging: false
position_output:
  output1:
    io_type: bluetooth
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
  output2:
    io_type: tcpsvr
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
positioning_settings:
  elevation_mask_angle: 15
  glonass_ar_mode: false
  gnss_settings:
    positioning_systems:
      beidou: false
      galileo: true
      glonass: true
      gps: true
      qzss: true
      sbas: true
    update_rate: 5
  gps_ar_mode: fix-and-hold
  max_horizontal_acceleration: 1
  max_vertical_acceleration: 1
  positioning_mode: kinematic
  snr_mask: 35

Base:

Simple system report
app version: 28.4-r0
current_network:
  ip: 192.168.43.33
  security: wpa-psk
  ssid: micha
enabled: true
mode: client
base_mode:
  base_coordinates:
    accumulation: 120
    mode: single-and-hold
  output:
    io_type: lora
    settings:
      cloud:
        mount_point: ''
      lora:
        air_rate: 9.11
        frequency: 868000
        output_power: 20
      ntripcaster:
        mount_point: REACH
        password: '***'
        port: 2101
        username: reach
      ntripsvr:
        address: ''
        mount_point: ''
        password: '***'
        port: -1
      serial:
        baud_rate: 38400
        device: ttyEXTS0
      tcpcli:
        address: localhost
        port: 9001
      tcpsvr:
        port: 9000
  rtcm3_messages:
    message_1002:
      enabled: true
      frequency: 1
    message_1006:
      enabled: true
      frequency: 0.1
    message_1010:
      enabled: true
      frequency: 0.5
    message_1097:
      enabled: true
      frequency: 0.5
    message_1107:
      enabled: true
      frequency: 0.5
    message_1117:
      enabled: true
      frequency: 1
    message_1127:
      enabled: true
      frequency: 0.5
bluetooth:
  enabled: false
  pairing:
    discoverable: false
    no_input_no_output: true
    pin: '***'
correction_input:
  base_corrections:
    io_type: serial
    settings:
      bluetooth:
        send_position_to_base: false
      cloud:
        mount_point: ''
        send_position_to_base: true
      lora:
        air_rate: 9.11
        frequency: 868000
        output_power: 20
        send_position_to_base: false
      ntripcli:
        address: ''
        mount_point: ''
        password: '***'
        port: -1
        send_position_to_base: true
        username: ''
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        send_position_to_base: false
      tcpcli:
        address: localhost
        port: 10001
        send_position_to_base: true
      tcpsvr:
        port: 10000
        send_position_to_base: true
device:
  power_on_bottom_connector: false
  privacy_policy_accepted: true
  role: null
  rv3_banner_shown: false
  usage_analysis_accepted: true
logging:
  logs:
    base:
      autostart: true
      format: RTCM3
      started: true
    raw:
      autostart: true
      format: RINEX
      rinex_options:
        logging_interval: 0
        marker_name: null
        pole_height: null
        preset: default
        satellite_systems:
          beidou: true
          galileo: true
          glonass: true
          gps: true
          qzss: true
          sbas: false
        time_adjustments_enabled: false
      started: true
      version: '3.03'
    solution:
      autostart: true
      format: LLH
      started: true
  settings:
    debug: false
    interval: 24
    overwrite: true
    simultaneous_logging: false
position_output:
  output1:
    io_type: bluetooth
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
  output2:
    io_type: tcpsvr
    nmea_settings:
      bluetooth:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      serial:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpcli:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
      tcpsvr:
        gga:
          enabled: true
          update_rate: 1
        gsa:
          enabled: true
          update_rate: 1
        gst:
          enabled: true
          update_rate: 1
        gsv:
          enabled: true
          update_rate: 1
        main_talker_id: gn
        rmc:
          enabled: true
          update_rate: 1
        vtg:
          enabled: true
          update_rate: 1
        zda:
          enabled: true
          update_rate: 1
    settings:
      bluetooth:
        format: NMEA
      serial:
        baud_rate: 38400
        device: ttyEXTS0
        format: ERB
      tcpcli:
        address: localhost
        format: ERB
        port: 9000
      tcpsvr:
        format: LLH
        port: 9001
positioning_settings:
  elevation_mask_angle: 15
  glonass_ar_mode: false
  gnss_settings:
    positioning_systems:
      beidou: false
      galileo: true
      glonass: true
      gps: true
      qzss: true
      sbas: true
    update_rate: 1
  gps_ar_mode: fix-and-hold
  max_horizontal_acceleration: 1
  max_vertical_acceleration: 1
  positioning_mode: kinematic
  snr_mask: 35

Hi Bram,

Thanks for your high appreciation again :smiling_face: I don’t want to let you down, so let’s jump to the troubleshooting of this issue.

The main reason for it is that the RTK link doesn’t depend on Wi-Fi on Reach. Wi-Fi is used to manage receivers via ReachView 3. Corrections can be transmitted from base to rover via Serial, TCP, NTRIP, or LoRa. So, we need to look for the root in another setup stage.

This guide describes how to establish the LoRa connection between base and rover. Please check the steps from this paragraph. I assume that you didn’t attach LoRa antennas on both units. There won’t be any transmitting data without them.

You can also watch this video tutorial. Don’t be misled by Reach RS2 units shown there - ReachView 3 settings are pretty the same for Reach RS+ except for RTCM3 messages.

Otherwise, you can establish an NTRIP connection. It can be accomplished with our free-to-use Emlid Caster application. You can check this guide to connect the base and rover to a mountpoint.

Hi there Kirill!

It has taken a bit of time but I finally was able to resolve my issues. Some settings were set wrong and I have no idea how they got to be be that way. But anyways, I managed to correct the problem and am now finally getting a fix. Here’s the log I kept for anyone experiencing the same problem.

===========================
04-05-2022
11:54
Alright, its wednesday the 4th and I am going to try to get these things going again.

12:30

I’ve been busy just setting everything up. Base is connected to my phone throught and is in receiver mode, rover is having a bit of trouble entering the same mode. It gets stuck in the blue led blinking fast setting.

32, rover entered hotspot mode and I am connecting to it now

35 it didnt show up in the app so I went to the IP. gonna turn off hotspot mode

40 tried that, it told me it would be rebooting but still in hotspot mode. does show up in the app now tough. So gonna try again via the app

41 I realized it might have to do with the strength of the wifi signal where I am right now. I will keep things set up but try again later.

10-05

10:13
Starting up the units again. Trying once more

10:43
I started going through the settings again and forgot to take notes… When coming to correction output I noticed that for some reason Rover was set to TCP server. Changed it to LoRa. Gonna go through the rest of the settings now.

11:00 Right now Base has this: Correction input = off. Correction output = LoRa. Then Rover has the oppposite. I will set postition streaming 1 and 2 to off as well.

08 When getting to the LoRa settings on Rover I noticed that the frequency was set to 2.6. How? I don’t know. Will change to 9.11.

10 YEEEEESSSSSSSSSS!!! I am FINALLY getting a FIX position! YES! YES!

===================

Hahah, that was it. Some faulty settings that I somehow didn’t notice even after going through the instructions step by step several times. Let that be a lesson for the future.

Thanks for the help and I will post here when I get my first mapping done.

Hi Bram!

It’s really cool that you did that trick! And I definitely appreciate your narrative style since I always wonder what will happen in the end :smile: Especially in this case, when the ending is so good!

I’ll be looking forward to your mapping results. As always, you can rely on our support if you face any obstacles :blush:

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.