Reach RS+ wifi connection problem

I was trying to connect the Reach RS+ to my phone hotspot. I turned on the mobile hotspot on my phone and tried to connect to RS+ with my hotspot by using the ReachView 3 app on my colleague’s phone. However, when I try to connect, the blue light on the RS+ keeps blinking fast, which lasts indefinitely and never connects. This issue happened with most of my coworkers’ phones and only 1 out of 8 phones was able to connect. How can I solve this problem? The firmware version is 29.2. A video link is attached for better understanding. link : reach rs+ wifi connection problem - YouTube

Hi Geonhyeo,

Sorry for the silence here!

I’ve checked the video. Is the blue LED blinking continuously? I need to know if the receiver returns to its own hotspot after some time.

As I see on the video, you tested on Android phones. Can you share models and Android versions of some of them? And model and version of the phone, that worked fine.

HI, Anna

Yes. The blue LED keeps blinking, and it never returns to hotspot mode. After that, when I restart RS+, it couldn’t find wifi and goes back to hotspot mode.

The phone that can connect well is Galaxy A8(2018), and the Android version is 9. And, my phone is a Galaxy Note20 Ultra, the Android version is 12. Other mobile phones that could not be connected were the Galaxy S8+ with Android version 9, the Galaxy Note 8 with Android version 9, and the Galaxy Note 5 with Android version 7, etc.