Reach rs+ stuck on loading

While surveying today my reach unexpectedly shut off, and when i tried to start it up again it just sat why the three lights blinking in series (aka loading). i let it sit for a half hour and it never finished booting and I never could get a wifi connection (client or hotspot)

when I made it back to the office i tried flashing the firmware (https://docs.emlid.com/reachrs/reach-panel/firmware-reflashing/) but it doesnt work. i get an error from the PC that the last device connected to usb malfunctioned. i’ve tried 2 different windows 2 machines, multiple usb cords, and multiple usb ports, none of which travel through a hub first.

i simply cannot get windows to recognize the rs+.

Also the reach firmware flash tool hangs at 50% while install ing “zlib.dll” so i cancel the installation and try again, the next time it give me an error during in stall, if i choose “ignore” on the error, it seems to install.

but the firmware flasher never finds the rs+ inorder to flash it.

The windows device manage shows the rs+ as an unknown device (device descriptor request failed)

Any ideas?

Hi Clint,

If I get it right that rebooting the device doesn’t help, please charge Reach overnight and turn it on again. If the receiver is still stuck in loading, please share the unit’s Serial Number with me via support@emlid.com. You can find it on the bottom of your Reach under the bar code. I suppose further troubleshooting may require some sensitive info from you, so I’d suggest continuing our discussion via email.