Reach RS: RTK-Correction Data from Govermental Service is loaded but not processed

Hello all

We recently bought a Reach RS to fast re-check the elevetions of our groundwater gaging stations (govermental offfice).
However, there is no processing of the correction-data sent via Internet-NTRIP-Service - swiss federal governement, see:

GPS Instrument:
Reach RS, bought 2017


  • iPhone 6 with ReachView App 2.9.3-r0
  • as HotSpot via WLAN, Internet-Connection worked
  • Test-Site near Berne, Switzerland, open sky, no obstacles nearby, 21 Satellites in range


  • Kinematic, Fix-and hold (tried also continous)
  • GLONASS off

Correction Input:

  • Address:
  • Port: 2102
  • Username:
  • Password:
  • Mount-Point: DGNSS_NAV
  • Format: RTCM2
  • Checkbox Send…:= on (also tried off)


Correction Input:
The device connected to swipos and data was downloaded/packages received, followed by brackets with diff. codes in it (Failure codes?). But nothing was processed:
ion(1), pos(1…), dgps(1…),
rtcm:1(1…), 3(1…), … 59(1…)

Positoning Mode: Single
Solution Status: Single
Age: 0.0 s (green circle)
ARratio: 0.0 (red circle)
baseline: 0.0 m (green circle)
no valid coordinates in switzerland-coordinate-system
no stable Elevetion between ± 2m

Has anyone a solution for the Problem? Thanks a lot.

Buying a second Reach RS for Setting our own base-station ist not an option, as there are many official reference Stations around which work great (with the more costly swipos-GIS/GEO Service). Have some experience with our outdated Leica-DGPS - ok costs a lot more…

Need more information about your setup. Could you please post setting used for correction input and RTK used on RS?
Screenshots are great as they tell more about the setup then the actual words

Several printscreens of parametrizations which did not work out

Most likely it has something with RTCM messages sent. RTCM2.3 is a older version and as i understand, you should also get code 18-21 for RTK to work. I dont think #1 Differential GPS Corrections will do. Someone els might elaborate this better

Hi Lukas,

As you can see in your own screenshot SwiPos NTRIP caster is broadcasting RTCM2.3 message types, 1, 3, 16, 22, 23, 24, 31 and 59; this means your Reach receiver is getting code only corrections for GPS and GLONASS constellations but it is not getting message types 18 + 19 nor 20 + 21 which means that with the information sent from this NTRIP caster mountpoint you can only compute a code only Differential GNSS position. Unfortunately I don’t know if Emlid’s Reach current firmware implementation is able to provide code only solutions, all what I can tell you is that RTKlib (engine running under Emlid’s ReachView) is able to compute that kind of positoning. You will have to ask someone from Emlid to clarify.


Hi All,

I have tried RTCM 2.3 code only DGNSS NTRIP feed (message types 1, 3 and 31) from a local network and I can confirm that no differential position is computed by ReachView 2.9.3


Hi @Hydrometrie,

Swipos compatibility has been tested extensively. Please use a RTCM3 mount point instead of RTCM2.

Tests with new updated Reach-View App (v2.10.0) today, still no solution to my problems.

Tried with our flat-rate swipos – GIS/GEO Account:
Reach-View Logged in to server but App did not process received mountpoint-list (RTCM 3, send NMEA…messages both activated and not activated were checked-out)
Also set to RTCM2…works not at all.
Our old LEICA-device was standing nearby, worked fine with the same account - off course it was shut down while testing Reach RS in order to avoid license-problems

If the emlid guys tried (successfully) swipos-gis/geo with reach RS then I would be glad to receive some screenshots with the parameters used.

Below some of the tested configurations, none worked…


Could you PM me with user and pass. I can give it try from here

Please PM me as well.

This topic was automatically closed after 100 days. New replies are no longer allowed.