Reach RS & Reach: RTKPost Insufficient Memory

I am trying to post process a track using a Reach RS as the base and a Reach as the rover.

I’ve collected the logs, converted them and attempted to post process using RTKPost as described in the documents. However, I am getting an error “insufficient memory” and have tried it on a number of systems, including one with 16GB ram.

Is 16gb not a sufficient amount of memory or is there another issue at play here?

Any input is greatly appreciated! The rover/base logs can be downloaded here:

I used to scratch my head about that one as well. The insufficient memory error means “insufficient program memory,” not that you have run out of RAM.

  1. If not already, try Emlid’s version of RTKPOST (download link is in the docs under post-procesing), as I believe will process larger files without getting the Insufficient Memory error.
  2. Use RTKCONV and the “start time” and “end time” options to split your RINEX output into smaller chunks.
  3. If using RTKLIB proper, then in RTKCONV use the “interval” option to thin down your RINEX output into a smaller size.

Curious. Just how long were you observing and at what frequency?

I don’t recall for sure… probably around 10-12 hours at 5hz.

I ended up using a CORS station as a base and had no issues post processing, though with some float where I am pretty sure almost all my data would be fixed if I could use my base data.

RTKPOST can behave erratically with big logs, that’s true. However, most of the time, if you wait long enough without closing the program, it will start processing.

12 hours with update rate of 5 Hz is a lot. Was the rover static? In genera, I would consider switching to 1 Hz. Also, RTKPOST has a feature that will let you take every n-th observation, reducing the required memory.

RTCM3 corrections are usually 1 Hz, so the RINEX is more lightweight.

Thank you for the tip. Please forgive the following stupid question…

I tried re-converting the logs with a 1 second interval, but when I tried to post process it said “Q=0” and produced no logs. If I change the rate to 1hz on the base and leave the rover at 5hz, will that be an issue? IE Can it interpolate the results? I think it must be able to since the CORS stations I’ve used at not 5hz… but the conversion issue above has me wondering.

The reason being, I have a homebrew logger on board my vehicle which collects data at a 2hz rate but at even time intervals… such as 14:53:23:20, 14:53:23:60, 14:53:23:00, etc - it’s nice to be able to import into excel and VLOOKUP the results against the post processed reach logs. If it were to change to 1 per second I suppose enough logs would fall on the “00” it would work but at 5ghz, every single log data point has a PPK results which is pretty awesome.

Update1: Oh, the base was static, rover was mobile the entire time.

Update 2: I tried again at the “5” interval rate for the base file with a file I know works… and it worked. So please forget my prior statement about Q=0. Must have had another issue at play on that one.

This topic was automatically closed after 100 days. New replies are no longer allowed.