Reach RS+ NTRIP caster cannot be reached


I have just recieved Reach RS+ for a test and I immideatelly run into problems with NTRIP. My company gets RTK correction from the VRS network and we have used it successefully so far. Now, when I try to connect to the same NTRIP with Reach RS+, I receive an error that NTRIP caster cannot be reached. I am new to Emlid products and might as well missed some settings but how can I use NTRIP with Reach RS+ in my case?

When I type IP address and a port, the page updates and offers me to choose from several mount points. However, it does nothing after that and the choice for mount point disapears. What is left is just a field to type text.

How can I use RTK correction with this antenna if when Wi-Fi is enabled for connection between a mobile phone and antenna, the mobile data automatically disconnects (thus unable to connect to NTRIP).

I appreciate any help that can help me to solve this issue.

Hi , most VRS services require a position from the reciever before it will let you connect.
A minimum of singel solution and have the the NMEA GGA message ticked. Is this done?

If so, could you verify Reachview version and post system report.

I normally use shared hotspot from the phone with RS. This should provide wifi and internet for your RS. Is that not your case?

@TB_RTK, thanks for fast responce. I tried to follow Quickstart guide again in case if I missed something. While doing it from the browser, I managed to connect to NTRIP. However, when I try to further connect Reach to the internet via my mobile hotspot, I run into problems. When I create a mobile hotspot and connect Reach to it from the browser, the phone shows “No devices connected” in the Hotspot menu. When I reboot my phone and my Reach, I cannot access the device anymore. It is not visible in ReachView in the app and morover it is not available anymore as Reach hotspot. The only way to get back to the device is to conduct firmware flashing.

Am I doing something wrong?

btw, in addition to my previous post, thanks for pointing out that the signal connection should be established before the connection to a NTRIP caster.

Not sure i follow you entirely.

Here you have successfully connect to Reach. Is it Reachs hotspot or something els?

and here you have lost the connection. It seems you lose connection going from Reach hotspot to phones hotspot.

You should first have saved a hotspot for Reach to connected to, then start the hotspot (with e.g you phone with shared internet connection) and finally boot up Reach.
You should see Reach connect to your phones hotspot.

I went once again through instructions (the 4th time) because it seems that I am missing something. So far I had experience only with antennas that connect to mobile phone via Bluetooth and I had no issues with them. Now, when the connetion should be via WiFi, it seems to be more complicated than I expected. Well, I ceated a wifi connection in ReachView before I created a mobile hotspot. After connecting to the newly created network in ReachView, the Reach jumped back to the older wifi. After the second attempt I managed to connect to the mobile hotspot.

So far, it seems that the device is able to maintain the connection to the NTRIP caster but I can only access ReachView via browser in my phone. Reachview app does not show available devices anymore. Is it

Also, the biggest problem I face now it that the battery of my phone dies within just 30 minutes when using the device. What can I do about it? I managed to make everything work fine but if the full battery charge runs out in just less than 30 minutes, I don’t see a point of using this device. I have my mobile data on for NTRIP, hotspot on for sharing internet with Reach and Bluetooth on for signal to Arcgis Collector. Any suggestions?

There is another way. I can try explain it as simple as i can.
1.Install Lefebure ntrip. (This tool runs in the background of your phone and lets ntrip data beeing fetched from the caster, forwarded via bluetooth to your RS units which has input correction on with bluetooth)
2. Pair up your phone with a RS unit
3. Set up input correction with bluetooth and use NMEA data (you can experiment with correction over TCP if you need to free up Bluetooth)
4.Start Lefebure and use External via bluetooth and select device you wish to connect. Go back a step and hit connect. If done right you should see data stream beeing sent
5.In Reachview you should see grey bars meaning correction data beeing pulled from the bluetooth connection. Next step you should activate position output over TCP. You will use your data collector to connect to RS hotspot and reciver its output solution over TCP.
6.Go into RS wifi menu and active RS hotspot
7. Open data collector and connect to RS hotspot, use stream sent over TCP the feed the collector with the output solution.

No shared internet on your phone.

The Lefebure NTRIP client is a gold mine! I am very satisfied how it works, thanks for pointing out to this software. It seems that I can entirely replace ReachView with Lefebure NTRIP and thus having the battery issue solved. I have Mock Location enabled on my android phone and use integrated reciever in Arcgis Collector. It gives me very nice results. However, there is an issue with the NMEA messages when using Lefebure. The height data recorded in Collector is ellipsoidal height and we need to tranform it using our local geoid model. The RTK correction contains information on geoid undulation and the ortho height but is does not transfer it to Collector. I assume if the new update of ReachView will be able to choose local coordinate system and upload geoid model, I would have to still use it in order to get the “right” data sent over to collector. It would be super usefull to get the right values using Lefebure thus eliminating the option of using ReachView. We only use Collector in our company and those guys who conduct surveys are not very that good in tech. Hence, less apps and less manipulations would be very beneficial.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.