Reach RS not connecting to Internet via WiFi to Update


I last used my Reach RS in August. I am now trying to update Reachview (I’m currently on v2.5.3-r0), but I cannot get it to connect to the WiFi. Here’s what I have done. I connected my phone to the Reach RS. In ReachView, I selected “WiFi/Bluetooth” and added my home Wireless network. Then, in the same location, I click on the network I just added and select “connect”. Now, using my phone, I connect to the same wireless network and try to detect the Reach RS using Fing on my Android phone (to then use the IP address to go back into ReachView, but now connected to the internet). No luck, it does not appear. I have checked the name and password of the WiFi network multiple times, turned everything off and tried again, and restarted and reinstalled Fing. No luck.

Any help would be greatly appreciated. I would prefer not to flash the device (I had to do that once and it is a pain!).

I used to have these issues with my Reach modules awhile back. I think it was an issue in the firmware(no certain), because I used to go through the same thing. It would connect I would make some changes, reboot, and no connection, but all my wifi info never changed.

Eventually I reflashed the module with the Emlid/Edison workaround and started fresh. It would let me in for awhile. I had to re flash one module a few different times to get it to keep connecting.

I haven’t had any issues once a new update came out. It has now been a handful of months with no issues on either of my 3 modules.

1 Like

Thanks DaneGer21, I appreciate the feedback. Before I flash, I’m going to wait a bit to see if anyone else has suggestions.

Note- this is happening on BOTH of my Reach RS units (one was not charged so I hadn’t checked it previously- now it is and it also is not connecting to WiFi).

Also as you noted, nothing has changed about my WiFi!

Just Received Our New RS Units, seems that the Same issue continues,
Hope the Units were Not put together by Laborers for the DPRK ??? LOL

Do you see which IP address is given to Reach?
And do your wifi credentials contain any funky letters or signs?


I could try helping you out but i need a bit more info then yes :wink:

1 Like

In Fing, are the IP addresses in your network in the range?
If yes, it seems Reach does not like this subnet because it uses it for something else.

One thing I tried: I set up my mobile as a hotspot (tethering) and had the Reach connect to that wifi network.
Of course that’s not ideal (at least on my Android mobile I cannot connect to my flat’s wifi while it operates as a hotspot, so any updates to the Reach would have to come through mobile data…). But it would definitely help to narrow down the issue.

Just wanted to touch base. I haven’t been able to work on this for a bit. I tried again today. Surprisingly, it worked. The Emlid Reach RS now appears in FING, so I can update with no problem. I have no idea why it did not show up before. I am doing exactly the same thing now as I did before.
Regardless, the problem is now fixed- though I wish I knew what I was doing wrong the last time.

1 Like

You can also use the new iOS/Android apps instead of Fing for this.

1 Like

Thanks, Egor. I can do this now since I have updated, but the original problem started when I was in v2.5.3-r0 so I couldn’t use it until I updated. Either way, the problem is solved now. Cheers.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.