Reach RS+ Flashing Failed Version 1.4.1


While Flashing a Reach RS+ the device “unplugs” itself and fails, creating a new use for the GPS on my computer. I have tried using multiple cables, multiple ports and two computers.

It will typically cut out after Device Installation and once the Flashing Hardware stage begins.

Flash tool version 1.4.1 and the latest firmware (2.22.7). I have attached the logs from most recent try. (35.1 KB)

If there is a step I’m missing, would be great to know.


Hi Zach,

Could you please elaborate on why you decided to reflash the device? Usually, we don’t recommend the reflashing procedure if the issue could be resolved by brief troubleshooting.

Please specify on which step the reflashing process fails. Is it possible to connect the device in the Firmware Update Mode?

Hi Polina,

Of course, the unit became inaccessible via the app after continuously receiving a blinking green light on the device. After many reboots of the unit and charging for a bit the device still had solid Power and Network lights while a blinking Status light.

Upon investigating in the forum I found some saying to reflash the device. I’m open to other methods to troubleshoot this problem though if you have any suggestions Polina.

The device fails after Device Initialization is completed and the “Flashing Device” reaches roughly 10%.

Hi Zach,

It seems like we’ve been in touch over email as well.

Do I understand correctly that the flashing process stops at the same step for both computers you tried to accomplish the reflashing with?

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.