Reach RS first-time setup

I have just unboxed 4 brand-new Reach RS but I can’t use them straight away because I am forced to update them (why do I need to update something that is brand new???) and my work wi-fi network does not let me connect to the units. There does not appear to be a way out of this impasse other than to take the units home and use my home wi-fi network to connect.

How can that be good design?

I would be very grateful if someone could point me to a straightforward guide to getting the RS past the initial setup stage when the only available wi-fi has extra levels of security.

Is there a usb driver that will allow me to connect the RS direct to my desktop so the update can take place? I have not been able to find one so far.

Thoroughly disappointed.
Ed

You can’t win them all Ed. I was about to take a long flight the other day and I wanted to get some work done over in-flight Wi-Fi, but I didn’t have any computing devices with me. I was able to purchase a (major brand) tablet at a store in the airport. When I got on the plane and after being assured there was Wi-Fi available, opened the box, turned it on and before starting up, it required me connect to a Wi-Fi network. At this point I was also disappointed, because although I could connect, it would not allow me to open up the web browser to click the check box to accept the terms and conditions, etc. The software needed to activate the device over the Wi-Fi first, but I needed the web browser open to activate the Wi-Fi. Catch-22. So I was stuck and could not continue until I was able to get to a traditional type Wi-Fi network with a normal router.

I was very disappointed at that point as well, and not able to do any of the work I was supposed to do.

But why? By the time you receive your unit, the software is usually out of date. By making you upgrade the software, both you and the company don’t have to deal with old bugs and support issues, plus you won’t be missing out on the latest features. Those things might leave you feeling worse than you do now. So I get the reasoning behind it. My unproductive day is over and behind me. If I wasn’t so much in a rush in the first place, I could have read or asked beforehand about what to expect as far as first time setup.


Moving on.

It can be a bit technical, but yes, you can do that. It is out of the norm, and not currently documented. What is involved is setting up ethernet over USB. I don’t know what OS you run, but if it is Windows then look at NDIS setup for ethernet over USB. You will have to set your NDIS driver to be in the 192.168.2.x network. When set up, you can access your Reach at 192.168.2.15 . When that is working, you may need to enable a type of network connection sharing from your computer’s network connection to the NDIS/USB. Then you may need to ssh in to your reach and register your computer’s 192.168.2.x IP as a network gateway with the route command.

Anyway, figuring this out may take you 10 minutes if you have done this kind of thing before or it may take you all day and still leave you scratching your head. It is probably a more sane solution to go find a normal Wi-Fi router and run the first time setup like everyone else.

Don’t forget that you can do the same thing by making a Wi-Fi hotspot with your smartphone.

There is a small catch-22 there to be aware of. You can’t have your phone Wi-Fi hotspot on while connected to Reach’s Wi-Fi hotspot. So you must first connect to Reach, then save your phone Wi-Fi essid name and password. Don’t click connect yet. Power off Reach. Now turn your phone hotspot on. Then turn Reach back on, and if you did it right, it will connect to your phone’s Wi-Fi hotspot and you should be able to complete your first time setup. Good luck!

3 Likes

You may need to change the subnet mask settings on your router. I can’t access the Reach from my home network either, and that seems to be the way to get it working. Granted, I have never done it as I use mine a work mostly.

Here are some details on that issue:

https://docs.emlid.com/reachrs/quickstart/

looks for this section:

Thanks for the advice, much appreciated.

I succeeded using my home network with one unit last night.

This morning I have used the phone wi-fi hotspot method to initialise the next unit at my work place.

Now I can start exploring the capabilities!

Thanks again.

Ed

1 Like

Further confusion!

I have successfully initialised two units using the phone wi-fi hotspot method but have struck a problem both times.

When connected via the phone hotspot ReachView performed as expected, showed status etc. I then returned the Reach RS to wi-fi hotspot mode. I could then start ReachView on my iPad and everything worked fine but when I tried restarting ReachView on my (Android) phone, the app could see the Reach RS but when I tapped on the line the screen went to dark gray, the Emlid logo did not appear and all is unresponsive (except for the back button that just takes me around the same cycle). I should note that the iPad has the app shut down and the wi-fi returned to my work network so there is no conflict there. I have tried uninstalling the ReachView app on the phone and reinstalling from Google Play store (loosing the latest update of course) but this makes no difference. I have tried turning everything off and on again - no difference.

Anyone had a similar experience that they have found a work-around for?

Update:

I found that I had to turn off wi-fi on the phone, turn it back on, log in to my work network, then choose the Reach RS hotspot, then restart ReachView. Now everything works as advertised.

A solution but no understanding…

Well, Reach broadcasts itself on the network so that your ReachView mobile app can find it. I can see how maybe certain situations aren’t handled well. Especially if you start the app in one network configuration, and then change your network configuration. Maybe there are some improvements to be made in the Android app.

Whatever the case, know that if your device is connected to Reach’s hotspot, the IP address is always http://192.168.42.1

So, even though it should always work, you only really need the ReachView mobile app to find Reach’s IP when Reach is connected to your Wi-Fi network.

I’m glad that you got it working and found a workaround for yourself as well. :slight_smile:

2 posts were split to a new topic: [solved] Touble with receiving corrections