Reach RS+ extension connector (RS232) no output debug

Our team can receive serial position output data from the USB-to-PC method, but we require RS-232, so we bought the extension cable to use the ‘UART’ position output method. 2.14 Reachview version. We have connected the RX, TX, and ground pins in accordance with the datasheet. We have matched the baud rates, serial port number, stop bit, etc. We tried different output formats NMEA, LLH, etc. Windows 10. We are using a NETmate USB 2.0 - RS-232 converter. There are no nonsense string outputs being received - it appears there is no output whatsoever.

Can you suggest some debugging possibilities or steps we didn’t consider?

Thanks in advance.

Hi @benjaminjcates,

Please post your hardware setup photos.


Let’s try to figure out if NMEA messages from Reach comes to your PC USB port. Can I ask you to do the following steps?

  1. Download PuTTY.exe app;
  2. Setup Serial output in ReachView;
  3. Run PuTTY app;
  4. Choose the “Serial” connection type;
  5. Specify the COM port and the speed;
  6. Hit “Open”.

Please post the screenshot of Putty window here.


Thanks for your suggestion and assistance, Tatiana. We have supplied the putty output screenshot as requested, along with settings in case an error of some type can be found there. Despite being able to receive via the USB-to-PC mode, but not via UART setting, we’re having difficulty identifying the cause of this issue.

A loopback test was performed on the pins of the RS-232 to USB converter using putty, and it was successful. So it does appears that neither the serial port, nor the converter is the problem.


Please unplug the converter from Reach and measure the voltage between following Reach RS-232 pins:

  • 5V output pin (8) and any GND pin (1-3);
  • TX pin (7) and any GND pin;
  • RX pin (6) and any GND pin.

Thanks again for your troubleshooting suggestions. We have measured the voltage between pins as follows:

5V output pin (8) and GND pin = 5.02V
TX pin (7) and GND = 3.84V
RX pin (6) and GND = ~0V

Hi Benjamin,

According to the measurements, it seems RS-232 port operates normally.

I’ve tested the position output over RS-232 port and it works. I use Reach cable with male connector and DB9 female to USB adapter.

Could you please provide your connection scheme or photos again? Please describe it as detailed as possible. Maybe there is something we both missed.

What’s the driver of Reach USB Serial device in Device Manager?

Does the issue persist with another unit?

Shouldn’t we see voltage changes that change with the NMEA message / signal being sent for RS-232? Here is a picture of the signal on the oscilloscope measuring the TX and GND pins.

the driver says “USB Serial Port” under device manager.

Thank you.

Hi @benjaminjcates,

You’re right, the signal measured with oscilloscope doesn’t look proper.

Have you tried to output the position over RS-232 from another Reach RS+ unit?

The problem has been identified. One Reach RS+ device we bought has a faulty RS-232 port. For the other units we have, the RS-232 port works just fine.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.