Reach RS doesn't turn on

Dear Sir,
I have a problem with Reach RS (SN EFD61513A453FSAD1736) unit because does not turn on.
The unit worked very well until a month ago. I used it as a rover with my new Reach RS2. After a pause of few weeks, the unit does not respond.
All the frontal LEDs remain off.
I tried:

  1. to reset the unit by pushing the button for 15 seconds;
  2. to power the unit for a day also using different USB cables including the original;
  3. to connect directly to the PC USB port and to use the Reach Firmware Flash tool;
  4. the unit is many years old, could the battery be off? In this case how to replace? Can you sell me a new pack? Or I can provide myself?
    Looking your news
    Best regards
    Marco Menichetti
1 Like

Hi Marco,

Is there any LED reaction when the power button is pressed?

Was the reflashing completed successfully?

Dear Svetlana,
thankyou for the reply.
Yes, the frontal LEDs remain off.
I tried all the options including point 3 of my previous message. Any reaction.
I tried different USB ports on different PC. The Reach RS doesn’t respond… seems dead.
Looking your news
Best regards

Having the same problem with both of our Reach RS units that have been sitting on the shelf for a few months. Seems like the batteries die in these units if they are not kept plugged in.

opened one of the units and the battery was at 1v, seems like the BMS on these is faulty.

I brought the battery voltage up to 2-3v with an external pack and it is now charging thru the USB header again.

Thank you for the info.
I am looking to know from Emlid the technical specifications for the new batteries.

Yet it is well written in the EMLID Receiver User’s Guide in the Storage section itself recommended for all electric devices using the batteries of the same type.
As a reminder :


To prepare Reach RS,RS+ or RS2 for storage:

  1. Charge the battery to at least 60%.
  2. Turn the device off by pressing and holding the power button for 3 seconds.
    Make sure that device turned off by checking that power led went out.
  3. Store the device at room temperature.

Check the device every 3 months and charge its battery to at least 60%.

To use Reach RS,RS+ or RS2 after storage:

  1. Press the power button to turn on the device.
  2. Recharge the battery.

Hi Marco,

Sorry to hear that you face such an inconvenience with the device. However, since it doesn’t show any signs of life, we can hardly investigate what went wrong.

Also, we can’t provide you with a spare battery. We don’t produce spare parts, and we don’t recommend open the devices since it violates its IP67 protection. Even if you manage to repair the device, it can be easily damaged by water or dust.


Could you please email us on regarding this case? We’ll try to check if there are any other ways to help you.

1 Like

Thank you Svetlana for the suggestion.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.