Reach RS+ corrupted projects, possible overheating

The rover shut off suddenly during a survey, I assume due to the excessive heat (104°F/40°C). I let it cool off and after restarting, it was unable to open the project or download points. I can download logs, but Survey data seems to be corrupted.

So I started a new project and repeated the survey with a new project. The second project seemed to go normally, however after I was done, I was unable to open or download the points from the second project as well. I used both the Android app and the http endpoint. The dev tools console shows no errors.

  • Is there a way to access at a minimum the epochs of my shots through some other means than the onboard app, such as SSH, file system, etc.?

  • In the future, is there a way to monitor the temperature to prevent a catastrophic failure in the field?

Firmware image and ReachView version. v 2.22.3
System report:

Simple system report
app version: 2.22.3-r0
'wifi_status, interface: wlan0':
- wifi_mode: infrastructure
- ip:
  is_added: true
  is_connected: true
  is_visible: false
  mac_address: 8C:F7:10:19:8D:88
  security: wpa-psk
  ssid: MySpectrumWiFicc-2G
  uuid: 4f4390a1-2101-4e2b-b889-0814139825ac
base mode:
  base coordinates:
    accumulation: 2
    antenna offset:
      east: '0'
      north: '0'
      up: '0'
    - 0
    - 0
    - 0
    format: llh
    mode: single-and-hold
    enabled: false
    format: rtcm3
    path: tcpsvr://:9000#rtcm3
    type: tcpsvr
  rtcm3 messages:
      enabled: true
      frequency: 1
      enabled: false
      frequency: 0.10000000000000001
      enabled: true
      frequency: 1
      enabled: true
      frequency: 1
      enabled: true
      frequency: 1
      enabled: false
      frequency: 1
      enabled: false
      frequency: 1
  discoverable: true
  enabled: true
  pin: '***'
    - - 902000
      - 928000
correction input:
    enabled: true
    format: rtcm3
    path: lora
    send position to base: 'off'
    type: lora
    enabled: false
    format: RTCM3
    io_type: tcpsvr
    path: :9028
device: null
    format: RTCM3
    started: true
    format: null
    started: null
  debug: false
  interval: 24
  overwrite: true
    format: UBX
    started: true
    format: LLH
    started: true
  air rate: 9.1099999999999994
  frequency: 902000
  mode: read
  output power: 20
position output:
    enabled: true
    format: nmea
    path: bluetooth
    type: bluetooth
    enabled: false
    format: llh
    path: :9001
    type: tcpsvr
rtk settings:
  elevation mask angle: 10
  glonass ar mode: 'on'
  gps ar mode: fix-and-hold
  max horizontal acceleration: 1
  max vertical acceleration: 1
  positioning mode: kinematic
  positioning systems:
    compass: false
    galileo: true
    glonass: true
    gps: true
    qzss: false
    sbas: false
  snr mask: 35
  update rate: 5

I have been able to SSH into the receiver, but it’s very unresponsive. The command line is frozen and I haven’t even been able to ls the directory once it’s connected, and the connection is lost after about a minute. I’m concerned that the hardware is permanently damaged.

I also tried sftp and it timeouts after 20 seconds, retires and get:

FATAL ERROR: Network error: Software caused connection abort

Long time ago (I guess on firmware v2.14 or something) I also had a corrupted project, but I didn’t investigate it further (data wasn’t that crucial).

What I would try to pull data off: connect with USB-cable to your pc. I think you should be able to run ethernet over usb then and if it’s wifi-issues, it should work better.
If you’re able to log in through ssh, check free space on the device asap. Maybe there is no more free space which will probably result in strange failure/behavior

1 Like

The wifi connection is working fine because the app updates with satellite data and I can read other projects without any issue. The log shows a ton of free space. But SSH itself is spotty. I’ll try the USB method to rule it out. It would be nice if plugging in the USB opened up the device filesystem like a flash drive, but that didn’t work.

Hi Ryan,

Could you please update your RS+ to the latest stable firmware version (2.22.6)? We’ve fixed the bug with the storing of the logs since the 2.22.3 times so now it should work just fine.

Regarding the temperature monitoring, you can check the battery temp in the ReachView by clicking the battery icon in the interface.

1 Like

Updated to 2.22.6. I still cannot open the two projects from that day. I can download the logs just fine.

I cannot download points in any format. It just spins with “Project export. Project is being exported. Please wait.”

Opening the project spins on “Opening project.” Is there any way to access the files directly and try to derive my epoch times and point codes? I can query the log files if I had this information.

Hi Ryan,

Please, check your PM. I’ve written you there.

I have exact same issue, minus the overheating, I tried to update to dev firmware when 2.22.7 didnt fix it, now my projects gone!

Hi Mark,

Welcome to our community forum!

Could you please check your private messages? I wrote you there.

At this stage, the troubleshooting requires some additional actions, that is why it will be easier to handle it in the private messages.

I will keep this thread updated once we will reach a solution.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.