Emlid

Reach RS+ Connection to Mobile Wifi Hotspots


(Scott Hamshaw) #1

I’ve been using three Reach RS+ receivers as network rovers by using mobile wifi hotspots, which has in general been successful. I’m using these as part of a university course so am having students try using their phones as the mobile hotspot.

I’ve been finding that about 2/3 of the time it works great, but a 1/3 of the time the Reach just doesn’t connect to the mobile wifi hotspot even though it sees it as an available wifi connection. You type in the hotspot password and then nothing happens. I’m doing this using a second device/laptop.

I haven’t been able to see a specific pattern (i.e. phone type, service provider, etc.) as to when it works and doesn’t. It’s worked for me both on various iPhones and Google Pixel so far.

Anyone have any insights into which phone types, providers, etc. in the U.S. cause issues with using a hotspot with the Reach RS+?

Right now, they are all on 2.14 version.

Thanks,
Scott


(Michael Lambert) #2

You might try taking a look at each network with Fing. You can find it on both platforms. The also have a desktop program and web app. It’s an easy way to check ping and strength.


(Timmyd) #3

Scott,
I have a Verizon jetpack that works 100% of the time. Oddly enough I can use my Google Pixel 2 XL as a hotspot but I can not use it to connect the the Reach unit (ie 192.168.42.1). It just will not work.


(Dariusz) #4

I think it is a problem with encrypted passwords. I was trying to use different networks this morning without success (3 different routers, 2 different mobile hot spots. Finally I’ve done that with the same mobile phones, but with OPEN network (change the settings in mobile hot spot, switch off encryption and make the network open).
Hope this would help.
And one more thing, when you use hot spot on your mobile, probably you will not be able to use ReachView app on the same mobile - your phone is not in the same network as far as I understand that.
Regards
Dariusz


(Scott Hamshaw) #5

Thanks @chascoadmin for the suggestion to look at Fing and network info.

@Dariusz Thanks for the suggestion. You can actually use the ReachView app on the same phone that has the hotspot enabled. I’ve used that setup a lot and it works perfectly on my iPhone 5S.

What I can’t quite figure out if I have two people, both with iPhones and both able to create a Personal hotspot (with the default WPA2-PSK encryption). For one, the Reach will connect right away to it, while for the other it just won’t connect.

I haven’t carefully tracked if it has only worked on certain phone models and with certain carriers. I will likely try to do so though.

Scott


(Michael Lambert) #6

It definitely might be worth looking into makes and models, but more importantly the chipsets and firmware they have. I am now running dev update 2.15.5 and networking issues went away, but before that I had trouble with my Pixel 2XL, but not my iPad or Verizon 4G router. Now they all work consistently. I know some people don’t like running development software, but you can always flash back If you experience problems. Since you have more than one device that might be a good control set, especially if you’re getting students involved. Flashing firmware has become a pretty normal part of almost all the professional electronics that we use in our business.


(Dariusz) #7

Hi @scott.hamshaw . I’ve just tried ReachView app and it doesn’t recognize my RS+ in network. The setup is:
Samsung S7 with android 8.0.0 (genuine, not rooted), WiFi hot spot without password (open), RS+ (new, from the box, unpacked this morning). RS+ is connected to my hot spot, I can see Reachview on my laptop (connected to the same hot spot), but the app on Samsung doesn’t recognize it.

Regarding WiFi connection - I’ve noticed one strange thing: my encryption method is WPA2-PSK, but when I was trying to configure that over ReachView RS+HotSpot (the initial mode) it always remembered it as WPA-PSK - maybe that was the problem?


(Scott Hamshaw) #8

@chascoadmin thanks for suggestion on trying the dev update. I just updated one of them to 2.15.5 for a different issue so if I the connection isn’t working for one of the receivers I have on 2.14, I’ll try it on the one with 2.15.5 to see if it connects.


(Scott Hamshaw) #9

@Dariusz When you say doesn’t recognize it, you mean in the app it doesn’t show up as available? I often have had to restart the app once or twice before it finds it. I don’t know if I’ve tried it on a Samsung device yet. I did have one android device where I had your issue of the app wasn’t finding the Reach even though it was connected. I remember seeing another thread from someone suggesting to use a network scanner app to see if you can find the IP of the reach and connect to it through the web browser instead. Haven’t tried that myself though.


(Dariusz) #10

Yes @scott.hamshaw, the app doesn’t show the device as available. I’ve restarted app few times, but it didn’t help. Generally, that wasn’t a big issue because I could connect laptop or tablet to my hot spot and use browser version of reachview. Browser version on separate device works perfect, without any issues, just type reach.local and I can play.


(Tatiana Andreeva) #12

Hi @scott.hamshaw,

Such behavior might be connected with Wi-Fi connection timeout. I’d recommend you to update ReachView to the latest v2.16 stable version where the timeout is increased.


(Harold) #14

I am new to this and have the same issue with mobile wifi hotspot. To get rover to work on NTRIP I had to use phone for mobile data connection and separate tablet to connect Reachview app to rover. When the rover was connected to the mobile hotspot for data successfully, The Reachview app on mobile could not ‘see’ Rover??? Should this work, am I doing something wrong.

So the process that worked was - enable hotspot on phone. Use tablet to connect directly to rover wifi. Then use tablet to tell rover to connect to mobile hotspot. Then connect tablet wifi to mobile hotspot. Then open Reachview app and connect to rover. So Rover is using mobile hotspot for mobile data and tablet is connected to rover via mobile hotspot.

This seems to be an awkward workaround having to use an extra device. I had expected from instructions available, for rover to automatically connect to known mobile hotspot, and for Reachview via mobile to be able to connect to rover.


(Michael Lambert) #16

Most of the mobile devices that I have used turn the Wi-Fi off when you turn the hotspot on?


(Tatiana Andreeva) #17

Hi @harold.rmsurveying,

Which smartphone do you use? Is it Android?


(Scott Hamshaw) #18

@harold.rmsurveying You can definitely use just one device, although I haven’t had it work all the time. I do that all the time with my iPhone. I’ve tried it with about 30 different phones with students, and most of the time it works perfectly, but some of the time the connection just doesn’t work (normally the Reach won’t connect to the hotspot). Still looking to see if I can find a common thread of why it doesn’t work. It’s easiest to have a second device available to do the initial connection of the Reach to the mobile hotspot device like you described, then you can just use the single phone.

If you can get the Reach to connect to the hotspot, then you should be able to access it via the app (try restarting the app a couple of times after connecting). On one phone, it wasn’t showing up in the app. However, on that phone it showed the IP address that the Reach was using to connect to the hotspot, so you could open the browser and go directly too it that way. I think you can download a free app that shows IP addresses of connected devices but haven’t done that myself.


(Harold) #19

Thanks for reply. If I enable hotspot on my phone first, then turn on rover, the rover does connect to the hotspot and will send/receive corrections data. So that part is working.

But the reachview app on said phone, still does not find the rover to connect to, as per screenshot. But does work with separate tablet.


The phone is OPPO x9009 with android v 5.1. It is good to know that this does work for other people. I will find some other smartphones to try with.


(Tatiana Andreeva) #20

Hi @harold.rmsurveying,

This issue happens with some Android phones. The only workaround I can recommend you is to use Fing app to figure out Reach IP address and open ReachView in any browser by entering Reach IP address.


(Dariusz) #22

Hi folks,

I’ve tested another solution:
Mobile modem (Huawei MiFi R218 from Vodafone.ie)
RS+ couldn’t find network produced by MiFi.

I changed the name and removed password, but it didn’t help.
Next idea failed.
Tested on v. 2.14

Cheers.


(Christian Grüner) #23

Update to newest firmware 2.16.1, and try again. Lots of work has gone into wifi for that release.


(Tatiana Andreeva) #25

Hi @Dariusz,

Have you updated to the v2.16.1? Does it help?