Reach RS+ Connection Issue

I just received a set of Reach RS+ units. I completed the “First Setup” successful on both units and everything seemed to be fine. Upon restarting the units to complete the steps for “Base and Rover Setup”, the second unit started up fine and appeared in the ReachView App but upon startup, the first unit cycled through the led lights as normal, then had solid power led light only, then had solid power led light and blinking stat light, then solid solid power and stat light. The network led never lights up except in the initial cycling of the lights. How do I get the unit back to where it can communicate with the app? Did I just get a bum unit?


Hi, If i understand correct there is no NET led after powerup cycle is done? The cycle might take some time.¨
You have tried to boot up the unit several times?
You could try a hard reset, push and hold the power button for 15 seconds and then boot it.
Let us know how this goes

1 Like

Hi Chris,

Could you please confirm if ReachView version installed on both devices is v2.18.1?

I tried booting up many times and the hard reset with no success. All of a sudden it seemed to work this morning. I was able to set this one up as base and the other as rover. When I got to the field the issue had returned. No WiFi connection possible and network light is not lit. It appeared to be sending corrections over LoRa. However, since I can’t connect to the unit via WiFi, I can’t see it in the app.

Both units updated to v2.18.1 at first setup.


Hi Chris,

I’ve already sent this info to you in the email, however, I duplicate it here.

We’ve released the v2.21.0 dev update that should fix the Wi-Fi connection issue. Please inform us if it helps.


This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.