Reach RS+ communication issue

Hi all,

First time posting here. I’m working on an RTK project involving RTKLIB. My setup is the following:

  • Reach RS+ as Base Station

  • Raspberry Pi with Raspbian 9.9 (Stretch) as a Rover.

I connected the raspberry to a Neo-M8T GNSS receiver via USB (/dev/ttyACM0 port) and a Reach M+ LoRa radio via UART (/dev/ttyAMA0 port).

Both base and rover LoRa radio are configured to match the frequency and air data rate (910MHz and 9.11 kb/s).

I have managed to achieve a semi-stable fix solution when moving but im having a lot of trouble keeping that state. Here is one of the tests I did:

Looking at the base data received by the rover it looks like there is a communication issue:

I believe all these gaps are what is making my solution less robust and prone to losing fix.

Has anyone encountered a similar problem? Does anyone know any way to correct this communication issue?

Here is the configuration im using on the Reach RS+:

base2

Thanks in advance.

Are the gaps consistently spaced throughout the RTCM3 file?

I suppose your should test the next faster and the next slower air data rate and see how it affects your recieved RTCM3 data.

Hi bide, thanks for your prompt response
Yes, the gaps are consistent throughout the whole file.
I just tried changing the air data rate to 18.23 kb/s and I’m still having this data loss in the LoRa communication between base and rover.

I attached the raw files related to the post in this comment since I couldn’t do it on the post itself.

Tests.zip (3.6 MB)

I hope it helps to understand the problem I’m having.

I think if you connected both devices to the same Wi-Fi network and set up the corrections throught a TCP port, then you could proove whether this issue is to do with LoRa or not.

Also confirm whether your rover is a Emlid unit or not.

2 Likes

Great idea, just tried it and got excellent results.

No gaps in this rtcm3 file.

So the issue must be in the radio link then. Could the gaps be due to electromagnetic interference? I make all my tests on the rooftop a few meters away from a bunch of antennas.

My rover is a raspberry pi running raspbian, getting the GNSS signals from a Neo-M8T receiver and getting the corrections via LoRa from a Reach M+ LoRa radio module:

Screenshot_6
https://store.emlid.com/product/reach-m-lora-radio/

I’m not using a Reach M+, just the radio module.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.