Reach Rover's data sending Garbled characters


I am getting the base corrections to Rover and I am checking Rover status through USB-Serial using FTDI device. Every time its sending garbled characters as shown in the figure. How to remove those garbled characters?

Even if the status is Fix, or Float or Single; its always sending those garbled characters.
This garbled characters actually affecting my coordinates sometimes so I need to fix this issue.
I checked my baud rates and everything is ok.
But just in case, my baud rate is 57600.
Can anyone please help me out here?

Thanks in advance @bide @egor.fedorov @igor.vereninov Regards

Can anyone please guide me? Any help would be highly appreciated.

Are you getting corrections and outputting solution through the same serial port? Check that you do not have “Send NMEA position to base station” ticked.

This option is in “Correction Input”, right? (Send NMEA GGA messages to the corrections provider (required for VRS)).
No its not ticked. I double checked it.

And Yes, the data I am receiving on Serial monitor is after getting corrections on Rover. And on the position output, I chose the Format “NMEA”.

But its always sending me that Garbled Characters as shown in the image in my first post. I even changed the serial port and used Arduino instead of FTDI but still same result.

This is my connection diagram:



This type of output, with partly scrambled characters, usually appears when there’s no GND connection between two devices, only TX and RX are connected. Could you check the wire you use is ok?

Hi @egor.fedorov thanks for your response. I tried putting all grounds common but still no change. I’m getting same results as previous.

This is my ground connecting common. I don’t have any clue what to do now? Let me know if you have any other opinion.

There are some cheap breadboard clones that do not make good connection;
Also make sure your power source provides enough power for reach and xbee!

  • possible RF interference from XBee antenna transmissions?

  • remove power from XBee and see if garbled characters disappear

  • possible RF interference from Reach Wi-Fi antenna transmissions?

  • disable Reach Wi-Fi see if garbled characters disappear

Not real familiar with changing of transmission modes, but based on little experience I have, I would look at the USB-Serial converter.

You appear to have a good data connection as the NEMA sentences appear to come through ungarbled.

USBRS232 devices usually pass information to the computer about the device each time it is connected. Things like baud rate, etc.

Is it possible that this is the garbled data? On Windows / Linux,etc. usually you can tell when the device is recognized by a tone/signal. Is there some way that the USB device times out and has to reconnect with each new NEMA message? I would at least look at this possibility…

I don’t know what computer you are using, but Windows 10 and maybe other versions do a default USB suspend in power saving mode. It’s possible that the computer is responding to the device waking up.

The dial up modems sent instructions over the same TX-RX lines as the data, so code was sent to tell when DATA started and stopped.

Could you save NMEA to file for a bit on Reach (which should be a pristine example). Also save the garbled output to your PC as a file and upload them both so we can compare them (with a hex editor)?

Thanks @bide for your response. Currently, I am not in the access of REACH module. So once i have, I will upload the files here.
Also thanks @RickJ for your valuable comment. I will see those possibility what you suggested.

Thanks @panky but I tried without breadboard but still same results. About the power issue, I will check once I have the access to REACH module.