Reach rover mode with emlid ntrip caster corrections

  1. Firmware image and ReachView version.

    Reach firmware & Reachview app: v.2.24.2

    *I am using the original reach modules. Purchased them when they 1st were released.

Simple system report
app version: 2.24.2-r0
'wifi_status, interface: wlan0':
- wifi_mode: infrastructure
- ip: 192.168.43.200
is_added: true
is_connected: true
is_visible: false
mac_address: FC:DB:B3:90:87:D7
security: wpa-psk
ssid: vta_drones
uuid: 39b8d248-4156-4aa5-a277-e3acc221cbde
base mode:
base coordinates:
accumulation: 2.0
antenna offset:
east: '0'
north: '0'
up: '0'
coordinates:
- 0
- 0
- 0
format: llh
mode: single-and-hold
output:
baud_rate: 38400
device: UART
enabled: false
io_type: serial
rtcm3 messages:
'1002':
enabled: true
frequency: 1.0
'1006':
enabled: true
frequency: 0.10000000000000001
'1010':
enabled: true
frequency: 1.0
'1097':
enabled: true
frequency: 1.0
'1107':
enabled: true
frequency: 1.0
'1117':
enabled: false
frequency: 1.0
'1127':
enabled: false
frequency: 1.0
bluetooth:
discoverable: false
enabled: false
pin: '***'
camera:
duty cycle: 20
enable: false
period: 2
polarity: false
constraints:
lora:
frequency:
- - 863000
- 928000
correction input:
input2:
address: 159.89.145.103
enabled: true
io_type: ntripcli
mount_point: MP2886
password: '***'
port: 2101
send_position_to_base: true
username: u76629
device:
night_mode: false
privacy_policy_accepted: true
usage_analysis_accepted: false
logging:
base:
format: RTCM3
started: true
correction:
format: RTCM3
started: true
debug: false
interval: 24
overwrite: true
raw:
format: UBX
started: true
solution:
format: LLH
started: true
position output:
output1:
baud_rate: 38400
device: UART
enabled: true
format: ERB
io_type: serial
output2:
enabled: true
format: LLH
io_type: tcpsvr
port: 9001
rtk settings:
elevation mask angle: 15
glonass ar mode: 'on'
gps ar mode: fix-and-hold
max horizontal acceleration: 1.0
max vertical acceleration: 1.0
positioning mode: kinematic
positioning systems:
compass: false
galileo: true
glonass: true
gps: true
qzss: true
sbas: true
snr mask: 35
update rate: 5
  1. I am trying to setup a single reach module as a rover receiving ntrip corrections from emild caster without a base. I think I have some configuration settings wrong. hoping someone can set me straight. Per this video this setup is possible: https://www.youtube.com/watch?v=YWz0mhOwFAg

  2. I followed the steps detailed here to configure the module as a rover. But I seems I am missing something.

I setup the unit as a base (I think) & I get corrections from emlid ntrip caster and it shows on the emlid caster website that the unit is connected as a base, but when I configure it as a rover I only get a message in the reachview corrections tab that states “waiting for corrections”.

I’m sure this is user error, can someone point out the error in my setup? Thanks in advance for any assistance!

Hi @vtadrones,

The Emlid NTRIP Caster can help you to transmit base corrections from one of your receivers to another. It’s not an NTRIP correction service, which means it doesn’t provide its own corrections.

To use the Emlid NTRIP Caster, you will need to enter base and rover credentials on your units. Please note that you should provide both units with an Internet connection.

I’m trying to use the Emlid NTRIP with the original Reach modules just like vtadrones. Hope you don’t mind me asking questions about a similar setup on your thread.

I can get the base and rover to work on the WiFi network at my house. This is with base sending it’s location to my Emlid NTRIP mount point and then the rover receiving it. Both devices show up in the ReachView3 app. But when I take the rover 2 km away from home it won’t get the correction data with an iPhone hot spot. I can connect to the rover with Reachview 3 but never get a fix and it never connects to the NTRIP server. Is this configuration even possible? What did I do wrong?

Thanks,
Robin

Hi Robin,

If I understood correctly you have a connection problem between the Rover and your iphone so the mobile cannot connect to the internet —> it cannot receive corrections --> the Rover will work in standalone mode and will never be able to switch to status Float or Fix.
As kseniia mentioned above you need to have internet connection for both receivers (Base and Rover).
In my opinion if the problem persists try with another smarphone or a 4G router.

1 Like

Hi Robin,

Reach receivers should get corrections via NTRIP fine when connected to an iOS hotspot with Internet access. Could you please clarify at which step of this video guide you face any difficulties? It will help me understand what might go wrong.

If you have another smartphone or a Wi-Fi router, you can test it with Reach to check whether the issue persists, as Zinedine suggested.

Thank you for the response. Understood on the emlid caster functionality.

I am still confused on a few points on how to set things up correctly.

Question:
If I am connected to NTRIP corrections network (not the emlid caster), can I use one module (receiving corrections from the NTRIP corrections network) or do I need to have two modules setup, one as a BASE receiving corrections and sending those corrections to a ROVER module?

Clarification:
I setup an account with a local NTRIP corrections network, california real time network (CRTN) and I am able to input corrections from this service. But it seems I can only get corrections if the module is configured as a base unit (see simple report below).

base report

Simple system report
app version: 2.24.2-r0
'wifi_status, interface: wlan0':
- wifi_mode: infrastructure
- ip: 192.168.43.120
is_added: true
is_connected: true
is_visible: false
mac_address: FC:DB:B3:90:FF:0B
security: wpa-psk
ssid: vta_drones
uuid: 6c4a7ea4-deb0-4caa-83c1-63d36a923399
base mode:
base coordinates:
accumulation: 2.0
antenna offset:
east: '0'
north: '0'
up: '0'
coordinates:
- 0
- 0
- 0
format: llh
mode: single-and-hold
output:
baud_rate: 57600
device: USB-OTG
enabled: true
io_type: serial
rtcm3 messages:
'1002':
enabled: true
frequency: 1.0
'1006':
enabled: true
frequency: 0.10000000000000001
'1010':
enabled: true
frequency: 0.5
'1097':
enabled: true
frequency: 0.5
'1107':
enabled: true
frequency: 0.5
'1117':
enabled: true
frequency: 1.0
'1127':
enabled: true
frequency: 1.0
bluetooth:
discoverable: false
enabled: false
pin: '***'
camera:
duty cycle: 20
enable: false
period: 2
polarity: false
constraints:
lora:
frequency:
- - 863000
- 928000
correction input:
input2:
address: 132.239.154.80
enabled: true
io_type: ntripcli
mount_point: OVLS_RTCM3
password: '***'
port: 2104
send_position_to_base: true
username: CRTNVTADRONE
device:
night_mode: false
privacy_policy_accepted: true
usage_analysis_accepted: true
logging:
base:
format: RTCM3
started: true
correction:
format: RTCM3
started: true
debug: false
interval: 24
overwrite: true
raw:
format: UBX
started: true
solution:
format: LLH
started: true
position output:
output1:
baud_rate: 9600
device: UART
enabled: false
format: LLH
io_type: serial
output2:
baud_rate: 38400
device: UART
enabled: false
format: ERB
io_type: serial
rtk settings:
elevation mask angle: 15
glonass ar mode: 'on'
gps ar mode: fix-and-hold
max horizontal acceleration: 1.0
max vertical acceleration: 1.0
positioning mode: kinematic
positioning systems:
compass: false
galileo: true
glonass: true
gps: true
qzss: true
sbas: true
snr mask: 35
update rate: 1

The problem with this is when I collect points in the field with this configuration I have to power cycle the unit and re-establish a new position after each fix because the position does not update (change to a new position) after it achieves fix. I assume this is beacuse the unit is setup as base, thus should not move after fix is achieved? But I cannot seem to get corrections from the NTRIP CRTN service when I configure the unit as rover.

My desired functionality is to collect multiple points in the field with a module(s) that is receiving corrections from the NTRIP service mentioned above without having to power cycle the unit.

I also tried to setup one module as a base receiving corrections from NTRIP and sending those corrections to a module setup as a rover via serial (sik radios). But this does not seem to be working either. The configuration for the rover unit in this two modules setup is below:

rover report

Simple system report
app version: 2.24.2-r0
'wifi_status, interface: wlan0':
- wifi_mode: infrastructure
- ip: 192.168.43.200
is_added: true
is_connected: true
is_visible: false
mac_address: FC:DB:B3:90:87:D7
security: wpa-psk
ssid: vta_drones
uuid: 39b8d248-4156-4aa5-a277-e3acc221cbde
base mode:
base coordinates:
accumulation: 2.0
antenna offset:
east: '0'
north: '0'
up: '0'
coordinates:
- 0
- 0
- 0
format: llh
mode: single-and-hold
output:
baud_rate: 57600
device: UART
enabled: true
io_type: serial
rtcm3 messages:
'1002':
enabled: true
frequency: 1.0
'1006':
enabled: true
frequency: 0.10000000000000001
'1010':
enabled: true
frequency: 1.0
'1097':
enabled: true
frequency: 1.0
'1107':
enabled: true
frequency: 1.0
'1117':
enabled: false
frequency: 1.0
'1127':
enabled: false
frequency: 1.0
bluetooth:
discoverable: false
enabled: false
pin: '***'
camera:
duty cycle: 20
enable: false
period: 2
polarity: false
constraints:
lora:
frequency:
- - 863000
- 928000
correction input:
input2:
baud_rate: 57600
device: UART
enabled: true
io_type: serial
send_position_to_base: true
device:
night_mode: false
privacy_policy_accepted: true
usage_analysis_accepted: false
logging:
base:
format: RTCM3
started: true
correction:
format: RTCM3
started: true
debug: false
interval: 2
overwrite: true
raw:
format: UBX
started: true
solution:
format: LLH
started: true
position output:
output1:
baud_rate: 38400
device: UART
enabled: false
format: ERB
io_type: serial
output2:
baud_rate: 9600
device: UART
enabled: false
format: LLH
io_type: serial
rtk settings:
elevation mask angle: 15
glonass ar mode: 'off'
gps ar mode: fix-and-hold
max horizontal acceleration: 1.0
max vertical acceleration: 1.0
positioning mode: kinematic
positioning systems:
compass: false
galileo: true
glonass: true
gps: true
qzss: true
sbas: true
snr mask: 35
update rate: 5

Hi @vtadrones,

It’s possible to collect points with 1 rover getting corrections from a remote NTRIP base station.

Could you please clarify whether the rover unit can get Fix when you set it as described in our Working with NTRIP service guide? If so, you can collect multiple points in ReachView 3 using the Survey tool.

1 Like

That did it, thanks for the help. I can now collect multiple points in ReachView 3 using the Survey tool while referencing my base which sits at my house about 2 km away over a hill.

I did have to switch security type to WPA-PSK instead of the default WPA2-PSK. This was for an iPhone 7.

I haven’t used Reach for a few years, but it’s amazing how far it has come. Impressive work Emlid!

@vtadrones Hope you have success too.

Cheers,
Robin

6 Likes

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.