REACH post processing problem

Hi, I was trying to do the post-processing with the instruction in the DOCS, but it didn’t work either for Calculating base position or Calculating rover track (Q=0 and Q=5). It didn’t get a fix and was on float status, but still I would assume it should work for base calculation? Or is it necessary to proceed with fix for any calculation? thanks in advance,

P.S. the distance of reference station is about 40KM, and the baseline is fairly short, only 10-20m.

I’m not sure if you are trying to calculate the base station position as an exercise. If not, then maybe this will help?

Monument 4-char Code: CARI
Monument Name: Port Blair
Latitude °: 11.61418
Longitude °: 92.71955
Elevation, m: 1
Monument Style: shallow foundation pillar

Otherwise, in RTKPOST.exe, you could try:

  • click Options button,
  • under Positions tab,
  • under Base Station choose RINEX Header Position,

and see if that works.

Please post screenshots of the options that you have used.

thanks for the advice, but there was something different: the coordinates of reference station of CARI (in Cardiff) I used is:

which I found on the website of OSnet and typed in manually because unlike the tutorial, there was only one .16o file and no headers containing the coordinate. is that in the right format?

I wonder is that the problem?

Hi, please see the snapshots attached, thanks:

Also, I tried to put the reference station in deg/m but it didn’t work either…

Hi, there was one thing I forgot to say that, I was using the reference data for the entire day because I wasn’t sure the time in the filename and readme is GPST or GMT (may I confirm which it is?), is that ok? but I’ve just tried to use the 18-19 one hour data and it’s not working either…

any help please… this is really weird and have no clue about where the reason is…

If you are using an OS base station, then just select “RINEX Header” for your base position - it will then take the position from the base station file. To use a full day’s worth of files, make sure to substitue a ? for the hour identifier in the file name - then it will use all matching files in that location - e.g. in your example, edit the RINEX OBS filename to cari198?.16o (otherwise you are just loading a single hours worth of observations).

1 Like

Hi, thanks for the advice, the RINEX from OSnet only contains the 16o file, and the pos info can’t be retrieved from it, so I put the position manually, which should be right (from the osnet). For the filename, since the system doesn’t allow it containing the ?, so I tried with the one hour file but it still didn’t work…

I now wonder if it’s because the testing time too short (only a few minutes)? thanks,

Select one of the hourly files in the file dialog, then edit in the ? in the field in RTKPost. It will allow you to do it - I do it all the time.

The position should be in the RINEX file - just select “RINEX Header Position” from the drop down. I post-process with OS base station data a lot, and this always works.

Definitely worth increasing your testing time, and making sure you are recording good quality data - also make sure you are recording Glonass as well (and select in RTKPost) as this will give you more satellites. You should record at least half an hour of good data IMO (although you will likely need much less to get a fix).

1 Like

Hi, many thanks for the advice, I just had a look into the RINEX file as text, and might find where the problem was: there might be some timing issues.

The actual time should be 201607161849 as the filename indicates, however, the timestamp of the ref RINEX is as the following:
CONVBIN 2.4.2 Emlid 20160711 163858 UTC PGM / RUN BY / DATE
log: /home/reach/logs/ref_201607161849.rtcm3

This should just be a timestamp of the system event, however, the following contents are recorded on date of 9th, Jul:


could this possibly be the reason? i will try to change that manually and see what happens, but i wonder, what’s the reason for this incorrect timing?

I just tried with the corrected timestamp but still wouldn’t work. i will give it another run and see what happens.

A different matter to note, it still cannot read the pos from header file (in the .16o file?), it kept saying ‘error: no position info in the header’. I can see it opened as text in such format and not sure if it’s normal:

is the approx. position with zero normal? thanks