Reach module no power / no boot / no led

Hey guys I have 2 reach modulers ( first version )
One of them wont boot at all.

They were working fine yesterday, no hardware change, all the time powered from a PC.

Now one of them its not recognised by the PC, no led status at all. Already switch power cable, same problem, Using a usb amp meter the dead one consumes 0.11ma powered from a USB cable.
The working one consumes 0.05a on boot, and then 0.14 when its working.

What can I do to troubleshoot this ?
Is it a good idea to switch intel edison boards between each other ? Can I know any test point of the reach board itself ( withoud the edison board ) to measure if the board / power regulator is fine ?
I can get another intet edison board on a local store

Please let me know, Im quite frustrated :frowning:

Have you anything els connected to reach?
What kind of power supply do you use? Tried a batterybank with 2amp output?
What reachview version did you run?
What lights shows on boot up?
If everything els fails, try reflash

Nothing connected to reach, only GPS antenna.

I did try to connect a 3DR modules… TX module is connected to the Base one.
RX module was connected to my PC using a FTDI cable, and I was able to see the nmea corrections sent over the wireless link on my pc, I did this to be sure that the wireless modules work, they did work, so I made the second cable for the second module.
Once it was connected, I power the module up using USB port and nothing happened… Well the radio module did turn on, and the green led stop blinking, thats because the link was ok
But I did not see any led on the reach module. There is power because 3dr radio is getting power from the usb cable, but reach module did not power up. I disconnected the usb, disconnected the radio module, and same issue, no led, nothing on the device manager.

I followed this tutorial
My modules are 5v TTL, but acording to the documentation it was fine

Yes I did try a battery bank with bigger output, thats why I use the USB amp meter to see if that was the problem
Im runing the latest reach vercion, I flashed with CMD yesterday the 2 modules
No ligths at all, windows did not see the board, no com port, nothings happens on the device manager
Thats why I can not re flash the module, its dead.

I guess is a power issue… Im getting a Intel Edison and Mini Breakout Kit now, to check the Intel module alone and to try to re flash it using that board. But how can I check if the Reach board its ok? Is there any shcematic to know how to troubleshoot any power issue?

I prefer to be an issue with the Intel board and not with the Reach module
Where does the TX and RX pin go? to the ublox or to the intel board?

Ok some update on this issue.
I got a Intel Edison Kit from a friend, I separate the ReachPCB from the Intel Edison
I place the Intel edison chip on the development board, and, nothing
is dead.

Next step is to place the new Edison Chip on the ReachPCB, but I want to be sure that I don’t have any power issue, because I don’t want to fry another one.

The PCB of the reach module, connected to USB does nothing without the chip, and It don’t show any power consumption on the amp meter. So there is no shortcut. I would like to test if the power regulator of the board is working, I guess I should have 3,3v and 1,8v on some pins, but measuring this seems to be a nigthmare without a microscope

So is there any schematic online to measure from any other place? I can figure out the ublox neo8 schematic and pinout, but I dont know where the 1,8v came from

I found 3,3v I gave it a try and it worked out just fine
I re flashed the firmware using CMD and its solved

My question is what caused the problem, and looking at the connector I think that if I missplace the connector on the other side, the Rx module was sending 5v on a SDA lines, this could fry the edison?

Sounds like a bad connection/failure and or in combination of corrupted flash or something in that order. Other then that i have no idea.
But glad you got things working again.

Just to clarify, it works now with the new Edison?

Yes, now its working just fine with the new intel edison board. I just flashed the firmware and it was working just fine. The old one is officialy dead.
I think that I missplace the connector, but Im not 100% sure about that.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.