Reach M2 orange light only

I am trying to set up a new Reach M2. Reach RS2 would just power on and present me with an access point. M2 lights the orange LED and that’s it - i.e. not what I would expect according to the documentation.

If I plug it via USB into a Windows computer, the computer finds the device Reach M2 (unknown) but the device gets unmounted in a little while.
I downloaded and launched Reach Firmware Flash Tool, chose M2, downloaded the newest firmware, connected Reach M2 in firmware update mode. Reach M2 is found by the Flash Tool and updating proceeds. During the update process I see briefly a new drive appearing (boot D: - Windows says there is a problem with this drive) and then a Neutis_N5_serial device appears while Firmware Flashing.
When the update has reached 100%, sometimes a COM port appears for Reach. Then Firmware Flash Tool says “Rebooting the device…” and stays like that for quite a long time. Then I get “Firmware update failed” and an option to try again. I have “tried again” a few times already.

Reach M2 also gets quite hot during this.

This is a new device we received as part of the M2 UAV mapping kit.

Two quick things that have helped me were to make sure you have a good sky view of satellites and try a wall charger for power input. You didn’t mention what your power source was, but I have seen power source issues cause this behaviour.

My M2’s stall on powerup sometimes too, about a third of the time. I find it happens most when i hook to a solar battery pack, or use a really long usb cable. But i have had it happen plugging into the wall as well with the supplied usb.

Usually unplugging then plugging back in a few times gets rid of the orange light.

I think the unit is hanging up trying to get an update. I am not sure if there is a way to turn off the auto update feature.

This is what I accomplished by hooking up a wall charger. I think the unit is really picky about the power and if something doesn’t go right with the solar or the battery then it just kind of freezes up.

I finally got it to update on the 10th time I think. M2 is much more finicky about power than I had expected. An USB cable with two connectors to get more power didn’t work, what worked in the end on the 3rd try was just another USB cable, not the stock one.

Likewise, powering it on a drone with a 5V 1A power supply didn’t work at all. What I did in the end was add another power converter that supplies a bit more than 5V - and that seems to be working.

I had to switch to 5V/2A.

Hi everyone,

The M2 indeed requires more power than an M+. We recommend using at least USB 3.0 rated power supply with it.


Understandable the M2 is doing L2 times the work! Haha

Very impressed with the M2 it is a large leap forward from the M+.

This funky orange light only mode deserves some mention in the documentation. See, I was getting it while connected to an USB3 port on my laptop and went away only when I managed to flash firmware on the 10th try on the same port. Almost gave up.

Hi Kris,

Thank you for your request!

We will consider adding that info to our docs.

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.