Reach M2 not working

I have a Reach M2 that worked in the past, sat in a drawer ~ 1 year and when i want to (re)use it these days, it doesn’t work.
It boots, i’m able to connect, i updated firmware. But it doesn’t get a fix. Not a single satellite detected.
I tried several power supplies + powerbank. In clear sky view.
What’s next that i have to check? Which logs could give me a hint about the root cause?
How could i determine if it is the antenna, the board, hard- or software?
Any help is appreciated,
thanks in advance,
br Johann

Check the weakest link the antenna cable, try swapping it for another. Ensure there is no debris in the connector, make sure both sides are fully inserted, make sure the pins are not damaged.

If you can access the UI power is not an issue.


Hi Johann,

Do you have another antenna to test this Reach M2 with? It’ll help us to understand whether the issue is with the antenna or the receiver itself.

What’s the status of the green LED?

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.