Reach M2 not syncing with LiDAR

I’m new to Reach, so forgive me if my doubt is already answered.

Currently, I’m using Reach M2 GPS for time-stamping. While, interfacing with LiDAR connection is failing. I’m connecting Tx pin from S1 port(Since I need GPS signal as input to LiDAR) and PPS from port C1. I have set communication to NMEA port as well. But nothing works for me.

What I am doing wrong can anyone suggest? I am attaching my screenshot as well where NMEA pin is not getting locked.


1 Like

Very interested to hear the community input on this issue - just in case we run into it too in the future.

Hi Aditya,

It seems like we’ve talked over email.

As I understand from your email and from the OS1 datasheet, LIDAR has NMEA GPRMC UART message support. Reach M2 outputs these messages with GN prefix only.

For now, it’s not possible to specify the talker ID. We’re considering adding this option to the ReachView app. However, I can’t provide you with any ETAs now.

Also, please note that Reach M2 can’t output one specific NMEA message. You can learn more about supported NMEA messages in our guide.


I just wanted to ask that as OS1 has limitation, that it only accepts GPS data in GPRMC format while M2 doesn’t support this particular format. So is there a way where we can settle on common grounds? Maybe using a mediator in between like Arduino?

And also if you are thinking of adding GPRMC format on ReachView app, then till when can I expect this feature?

Hi Aditya,

You can use a third-party board so that a special script can change the output to GP string. However, I’m afraid that I can’t be of much help with it.

At the moment, I can’t provide any exact dates.

@tanish At one time on the OS1 you could configure the parameter: nmea_ignore_valid_char

From the docs I had on hand it reads if set to 1: messages should be used for time syncing regardless of the valid character.

Page 18 in the software user guide:

See if that helps…

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.