Reach M2 No Solution and No Sattelites

Hi All,

I have recently purchased a M2 and Mettatec PPK kit to install on my P4PV2. After updating the firmware and setting everything up, i get no solution and no satellites in view when i am outside. What trouble shooting steps can i try? I am using the stock antenna that comes with it.

TIA

Can you show us a picture of your installation ?
What antenna are you precisely using ?

It is just the standard Emlid cylinder antenna. Power connected to S1, trigger connected to C1.

Do you have another antenna or extension cable you try with? So we can rule out a bad antenna.

Unfortunately not, only the M2 and antenna i received from Emlid Australia

Hi @Brocxen,

Have it worked like this from the very beginning? What is the LED status of M2 when the device is placed outside?

Yea it has been like that from the get go. Also tried red lashing firmware.

See attached image.

@Brocxen,

I see, thanks! The green LED is solid, right?

yes, seems to be an issue between the antenna cable and the antenna

Try disconnecting antenna cable and reconnect.

Hold antenna up vertically with clear sky view instead of sideways near the ground. Prob your settings not right also.

Hi @Brocxen,

It’s unlikely that the issue is with the cable connecting the antenna with Reach. But without checking the antenna with another receiver or some other antenna with this M2, I can’t say this for sure.

Can you please share a serial number of the device along with a Full system report? Please, send it to support@emlid.com. I’ll check if there’s anything wrong with the hardware side of the receiver.