Reach M2, M+ and RS+ without access

I can’t access the dashboard of my devices! Yesterday, June 26, I did some work and they were all accessible. Today, when I tried to download the files, I couldn’t access them. I tried using iOS and Android, both failed.
1- The device is in hotspot mode, it appears available in the list of Wi-Fi networks. When I click to establish a connection via WiFi, the connection is complete.

2- I ran the Emlid Flow app, and the device appears.

3- When I click on the device to connect, it doesn’t connect.

4- I’m using the Emlid Flow app on iOS, it’s in version 10.8.

The previous images show me trying to connect to the Reach M2, but the same problem occurs with my Reach M+ and Reach RS+
I would like the community’s help to fix the problem. I don’t want to reset it, because I can’t lose the raw data contained in the devices.

1 Like

After joining receiver’s hotspot wifi, did you try connecting to receiver using a browser nearby such as Safari using


Hi Michael,

Welcome to the forum!

Can you connect to the Reach Panel? To access the Reach Panel, you need to connect to the Reach hotspot and type the IP address If it’s successful, please download and send us the Full System Report. The Full System Report contains some personal information, so please send it to

Do you happen to remember the firmware version of your units? Is it the latest 31.8 version?