Reach M2 + LoRa and Reach RS2 Problem

Got an issue with my hardware and trying to figure it out.
Reach Rs2 (updated to latest firmware), setup and getting 27-30 sats on my test as a base.
Reach M2+Lora and a U-blox ANN-MB multi-band GNSS antenna from Drotec.
My problem is that even though i updated the M2, i dont get any satellites and also no info from RS2, even though i can see the LoRa Rx/Tx communicating.
Within my tests i decided to test the latest Dev FW with no change as also another Non Multiband antenna i had in our workshop again with not even 1 satellite.
I would appreciate your help and ideas.

Might be an stupid obvious question, but as it isn’t explicitly stated, I’ll ask anyhow: Are you outside when trying?

@wizprod my apologies for not making it clear, but when i typed that my RS2 was getting 27-30sats, that it would of made it obvious that i did all my testing outside.
Since this is my first time with the particular emlid product, i wanted to ask if i am supposed to see my “base” sats on my rover, even when my rover has none. This way i will know that my lora is working properly. Because for now, seeing Rx activity, makes me think that in theory it does.

I decided to run another series of tests this morning (always outside) and what i decided to do is to measure the Vcc output on the antenna for the M2.
Based on the specs found at https://emlid.com/reach/#specifications measurement should be 3.3v and based on my antenna specs 3-5v if fine to run this antenna.
I did 2 sets of measurements and at best i was able to get 3V and nothing more, but most of the time i would get between 2.85 and 2.96v
Maybe this could be the problem? @tatiana.andreeva is there a place that you have the emlid antenna specs?

Hi Antonios,

All of the information about the Reach M2 specs can be found in our online docs.

May I ask you if you tested your Reach M2 with our recommended GNSS antenna? Could you please share the raw data log and position log from your device recorded in an open environment?

@polina.buriak The specs i was asking are not the M2, since my antenna Vcc measurements and results are based on those, but i was asking your recommended antenna specs since at the moment of purchase from my supplier i was able to get the one i have and not the one you sell.
I will upload all raw data files i can get

Antonio, you might check the power supply.
You might not have enough juice to supply antenna.

I’m using the Harxon GPS 500 antenna and using 5v 2amp power supply with M2.

@EBE111057 from my S1 port i have Gnd and Vcc directly powered by a MAUCH 3 amp BEC.
Quality-wise, it does not get any better than that. And i also tested 3amp out powerbank on the USB.

After seeing all the help i got from the factory for my 2.5k purchase, i decided to solve it on my own.
Got a second M2 and an emlid Antenna.
Tested the new unit on my existing antennas with no luck, tested on the emlid antenna and worked instantly. Tested my first unit with the emlid Antenna and at this point i hope that RMA is not their online assistance. I dont easily bitch like crazy if i see that the other side has something to offer, but having this post for three days and hearing only about the recommended antenna, makes me feel upset.
Thank you all for your time!

The Emlid helical antenna for the M2 is a good antenna in open skys and checked with known NGS control marks. I’ve used it several times for static positioning, however it’s not in NGS database for OPUS use. Positioning results for 1 hour observation was < 2 cm horizontal and vertical for approx 30km baselines. I use it as a backup if needed as I have the Harxon GPS 500 for both my M2’s. It’s in the NGS database.

1 Like

Could you kindly show your setup? and provide links to the antenna, cables, and power bank that you used? Thanks

I used a standard PVC drain pipe and end fittings I got at Home Depot. I counter sinked the base of the antenna approx 5 mm into the end fittings cap for added support for the antenna. There’s only two small screws for mounting the antenna. I used a drill press to get an accurate center for the mount. It works good although I didn’t plan on making the mount a specific length. I also used a standard female/male 5/8-11 survey adapter for the bottom fitting to screw into bipod to mount. I had planned on making it long enough to enclose the M2 and battery in the center section, but I’ll revise later since I’ve got the other antennas.

1 Like

2 Likes

2 Likes

I am doing something similar but I followed this advice from the Doc section of their webpage

Helical antennas do not require ground planes. They are robust and demonstrate good performance.

Still, a ground plane can improve observation quality significantly. In some cases, it might be reasonable to mount a helical antenna on a ground plane for safety redundancy.

I added a 1/8" plate 100mm diameter up top. I haven’t built the body yet. I am looking for a project box I like right now. Your PVC thing is a good Idea, I just might do that but bigger diameter to accommodate battery/M2/LORA. Thanks

The only problem with using the helical antenna is using in commercial PP software. I’ve got 3 separate software packages and there are no listed templates. I created a template to use in GNSS Solutions software (no longer updated or available for purchase) using the phase center distances listed in Emlid’s website for the M2. I’m cautious using the antenna for precise orthometric heights. That’s why I bought the Harxon’s

1 Like

I keep the M2, battery (5v, 2amp) and cables in blue bag hanging off bipod. When finished, I put everything in my hip belt pouch (lower left of image on ground). It’s pretty comfortable carrying with me, when I get to get out in the field. I’m mostly an office Surveyor :frowning:

3 Likes

To be honest, I have never done any post processing. All the data I use/need is referenced off the a benchmark set by a monitor which is truly referencing the the base LLH. This is why I asked for stored base locations.

We might setup a new base, and do a topo survey of some ground today but not go back to the field for 2-3 months. When we go back, we mount our base in the exact same physical location, pull the base from the saved locations which assigns it the same LLH and go to work.

One thing I like with the Emlid, it is easy to “survey” your base in with our CORS network, get a 5 minute average in fix. I have to do a bunch of monkeying around to do that with the Trimble base that we use

2 Likes

has anyone managed to make the M2 work with a pixhawk?
As i said above my original unit does not work from the factory, even with the Factory antenna. My new unit works with the factory antenna as a standalone but not with a pixhawk. I tested Cube with regular carrier board, Cube orange with Adsb carrier and also a standard pixhawk. No matter the settings (followed the docs, followed this forum, followed everyone and everything and feel like a stalker ) I cant get to have any signal on GPS2, status is always 0. From all the doc settings if i change serial4 from 20 to 5 and i plug any GPS from the worst banggood to a really good L1 i can see GPS2 on my screen. My M2 S1 port has Tx to Rx as supposed too RTS, CTS and Gnd connected. power is external from Mauch 3amp Bec. Any nice ideas?
@tatiana.andreeva @polina.buriak @dmitry.shilnenkov

Hi @tonyantzoulatos,

The link to the specs page we shared above contains the recommended antenna specs: antennas that require less than 3.3V and 100 mA should work with Reach M2.

We asked you to test this Reach M2 device with our antenna to eliminate the possibility that this issue might be caused by the particular antenna you work with.

I’ve just tried Reach M2 with this antenna and it works. At this stage, it seems that there is indeed something wrong with the device. Please contact us on support@emlid.com with the following information:

  • order date and number
  • your shipping address
  • Reach M2 Serial Number (it’s printed under the bar code)