Reach M2 and RS2

hi all
I’m new here I just receive a RS2 and a M2 to test i got few issues
I downloaded the app for android
and tried to connect to RS2 I can connect to hotspot wifi but when I clic on REACH RS2 192.168.42.1
it says “not responding”
and that’s all
on the Reach M2 side (tested alone) I tried to folow this :
https://docs.emlid.com/reachm-plus/common/quickstart/first-setup/
https://docs.emlid.com/reachm-plus/ardupilot-integration/
and unfortunately when I plug the usb for powering the rover unit only the orange led is lighting up solid nothing else light up nor solid nor blinking (no hotspot neither)

thank’s for any help

I succeded to connect to RS2 but thought pc
but it looks that update it’s not available (I’m connected to RS2 over wifi and to internet over Ethernet link)
here’s a screen copy of status panel

I recommend to use the flash software of Emlid for the upgrade
https://docs.emlid.com/reachrs2/common/reachview/firmware-reflashing/

Also for your message “Not responding”, use only the wifi hotspot, no ethernet connection on your computer

i finaly succeded in connecting to M2 hotspot I’ve setted up my wifi connection but when rebooted I found the IP on networks but can’t connect to the M2 server trought pc web page
on the other side it works only if I use my pc usb if I use a usb hub, a wall plug usb, or if I power it trought a pixhawk gps port : I have only orange power led that light up

this means the power is insufficient

1 Like

ok that’s what I was thinking … but even when i powering it correctly and having slow blinking blue led
I found ip on network,


but I can’t connect to web server on it

sory I’ve change nothing and just let the M2 powered during 1hour and just retry to get web page and it worked
I dont understand …

Hi Olivier,

This unit has quite unexpected behavior. May I ask you to generate the full system report from this unit? You can follow these instructions. It will help us to understand why this situation happened.

Please send the report in a private message, since this file contains a confidential information.

ok I will do that shortly
I think I have a quite stable configuration now I can tackle pc web page from both m2 and RS2 almost each time ( I think m2 is realy long to load up even after having long blink blue led )
now I just try to link up corrections as RS2 has no serial input i just try now to setup tcp correction link
in base panel for RS2 I have this :

ok rtk gods are one my side thank’s to your greate help I finaly succeded in connecting M2 and RS2 trought mission planner and inject corrections in ardupcopter GPS2 as explained in https://docs.emlid.com/reachm2/ardupilot-integration/
I’ve a question : must I see correction (grey bar) in M2 rover web page status panel when injecting correction data trought mission planner ??
because I well see correction data into rtk/inject mission planner pannel but didn’t see any grey bars in rover status panel and the rover position looks noisy

Hi Olivier,

Sorry for the delayed response.

I’ve a question : must I see correction (grey bar) in M2 rover web page status panel when injecting correction data trought mission planner ??

Yes, the grey bars should be represented in the ReachView if the rover obtains corrections. May I ask you to describe the connection details?

hi anastasiia
thank’s for your reply
to connection architecture heres what’ve done
RS2 M2 and my computer si connecter over local hotspot wifi
mycomputer that act as ground control (mission planner) is also connecter on a dedicated herelink wifi hotspot over udp trougth a cube black flight controler
M2 is linked to cube on GPS2 port and configured as described in tutorial https://docs.emlid.com/reachm2/ardupilot-integration/
Mission planner is well connected to RS2 over tcp:9000 and all green for base gps beidou etc …
I cant make screen shots because today I can’t connect to M2 webapp I dont understand why I’ve check it’s well registered over wifi and IP is pinging right but web app never ends to load
I’ve tryed several times rebooted etc but nothing want’s to load I’m just testing indoor for now but normaly it work to get webapp

ok i finaly found my problem!!
may I suggest to add in tutorial page to set SERIAL4_PROTOCOL to 5 (GPS) ?

1 Like

Hi Olivier,

Glad to hear that the issue is solved now!

I’ll try to reproduce your workflow with the parameters you mentioned. Thanks!

Also, since you’re using the Cube controller, it can require additional parameters for the configuration.

Hi Olivier,

That’s still strange that you couldn’t access the Reach device earlier. Is there any chance you remember the LED status on the device when it happened?

May I ask you to generate the Full System report on the device so we can investigate further why you faced this behavior? You can follow these instructions. The full system report consists of confidential information, please send this file in the private message.

ok I will do that today
it’s strange especially because for exemple both base and rover can conect correctil to one wifi few days ago and now only base do it alright rover is not even seeing ssid
thank’s for your help I’ll send you private message today with full report from base and rover side

sory it looks that new users can’t upload new files
I ve put zip on a google share point but it looks that I can’t send you private message
what can I do ?

any way thank’s for your help
I take this chance for saying that I have only 0.7m HDOP on gps2 (rtk one) even with a rtk fix status is there a way to configure for a better hdop ? is it normal ?

Hi Olivier,

DOP values determine the influence of satellite geometry on the positioning accuracy. The values not exceeding 2 are normal. When the DOP value is higher, the accuracy might be decreased due to the bad satellite geometry affects.

Hi Olivier,

We have added some improvements in Wi-Fi behavior in the v2.23.4 dev release. It’d be nice if you’ll be able to test it to check if it helps to eliminate the issue with accessing the device completely.

I’d like to point out that dev versions are mostly used for testing purposes and not intended for use for real field projects. Please note, once you update to the dev version, returning to the stable release will require the reflashing of the unit.

This fix will make it into the stable branch in one of the next updates, so you can wait until we push the stable to check if it resolves the issue.

1 Like

This topic was automatically closed 100 days after the last reply. New replies are no longer allowed.